Skip to main content
Помощь

Оригинальный сообщение: tattoobliss ,

Текст:

EUREKA!  I solved the problem, and I want to thank you jclark for giving me an idea that led to the solution!  Although what you suggested about the GPU solders was not my problem, your explanation of how the light not coming on the charger meant that the motherboard wasn't completing a full circuit was the explanation I needed in order to find my way out of the forest of failure Heheh

In my quandry, I was scouring search engines and thus led to all sorts of websites for diagnosing all manner of Mac problems, and it frustrated me that so many people would come on various forums, ask for help, and then never update as to what ultimately happened with their machines.  Oftentimes, some people would literally post 2 years later, "I'm having this same problem, what was the solution?" only to be greeted by the sound of proverbial crickets.  Well, I don't want to be that person, so here's my solution and I hope it helps a lot of people:

It was the battery connector cable.  I'm talking about this in case you're unclear:

[product|IF185-045]

I personally am not as cynical as jclark as to the quality of parts that one can find on eBay so I really didn't believe that I had bought a bad DC MagSafe Sound Board / Left Logic Board.  Jclark's explanation of the completion of a circuit made me think about the battery connector cable, and how possibly this too could have been damaged as power was not flowing correctly since one pin wasn't connected.  SOOOO, luckily I had bought anoter battery connector cable from iFixit BEFORE I even took the computer apart in order to rectify my battery charging issue (which wasn't the problem, just had a crap batter), so I swapped this out, replaced the thermal paste on the CPU/GPU/Northbridge (I used MX-4 btw, the best non-conductive thermal paste, and I used to be an Arctic Silver man all the way), and when I got to the keyboard I didn't screw it down, left the battery out, and connected the power adapter and VOILA!  Success!@!

Also, in getting to this point, I broke out my multimeter and tested the power coming out of the power adapter in the interest of ruling out that I had damaged THAT in the process of connecting it to my old DC MagSafe Sound board / left logic board when I broke the pin and I want to just quickly share with you that I found the pinouts for the power adapter here:

http://en.wikipedia.org/wiki/MagSafe

and so, first I stuck the testing probes in the AC power cord unplugged from the DC converter, here luckily I also had a 60w power adapter (both are genuine Apple and not 3rd party chargers) that I KNEW worked from a friend so I actually had some basis for comparison.  I measured 10.6 volts on my multimeter from both cords, so I knew that mine was still undamaged, but when I touched the probes to the MagSafe connector things became more ambiguous.  Becaure while I was able to rather easily measure about 7 volts from pins 1&2 and 4&5 (for a total or 14 volts, under the 16.5 volts the 60w is rated for on the outside of the plastic transformer case), on MY 85w power adapter I was only to catch a 7 volt reading for a split second, and most of the time would measure about .75 volts from either pins 1&2 or 4&5.  So really, I thought I had damaged the power adapter too.

Once I used the new battery connector cable internally to connect the DC MagSafe Sound board / left logic board to the main motherboard with the CPU/GPU/Northbridge, I tried the known good 60w power adapter to see whether a light would come on it, and it did, and once it booted all the way into OS X, I shut it down and connected my 85 watt power adapter and it worked too.  So the readings I got from my multimeter that were really low apparently just caused me consternation unnecessarily.  So, maybe someone who knows more about multimeters than I can contribute some knowledge as to why I got those funky low readings on my 85w power adapter when I got an easy 7 volts from either ground and positive pin pair on the MagSafe connector of the 60w power adapter, but I can't give a sufficiently scientific explanation myself.

So all in all, everything is cool except for one thing now - I can't adjust the brightness of the screen.  The F1 and F2 keys don't do anything, and I googled this as well of course and there's supposed to be a brightness slider in the Display preference pane in System Preferences but there isn't on this laptop.  The version of the OS is 10.4.11.  Now that everything is working normally, my next project is to upgrade the OS onto a new HD, and this may solve the problem but I'd like to be able to make the screen brighter as it seems to only be as bright as when it initially dims after you haven't touched the screen for a few minutes.  FWIW, the F9 and F10 keys to adjust the brightness of the back-lighting on the keyboard also don't do anything, however in that case, at least the big icon flashes on the screen and there's a tiny "no-smoking sign" underneath it, so that seems to be working more properly than the F1 and F2 keys, which when pressed do nothing whatsoever.

Thanks once again to jclark and I hope this helps somebody else! :)

Статус:

open