Перейти к основному содержанию

Отремонтируйте ваше устройство

Обучение ремонту

Магазин

Помощь

Текущая версия: oldturkey03 (подробности голоса) ,

Название:

no power to MacBook, new parts, other odd behavior

Текст:

I just received this A1278 EMC2419, MLB# 820-2936. I have very little history on it other than: MacBook stopped powering on, previous owner said they replaced:
 
* Battery
* MagSafe charger
* DC-in board
 
I can confirm the Chinese battery is new, the charger was still in plastic, but the DC-in board showed corrosion despite looking otherwise brand new and having a 2015 date stamp.
 
The MacBook doesn't respond to the power button, or to shorting the power pads. the MagSafe illuminates green with or without battery connected, and the battery level indicator is non-responsive *unless* the MagSafe is connected. I have attempted SMC reset, though I cannot be sure it has completed. I've shorted the pads at R5001 (omitted) which according to the internet will pull SMC_RESET low. That didn't have any apparent effect.
 
I set my SPI programmer with SOIC8 clip on the EFIROM, to attempt a reflash there, and strangely enough, the MagSafe turns orange when my programmer is connected and powered on. I'm unsure if that means the battery is charging, or that the SPI programmer is drawing current and tricking the MagSafe. Due to the precarious nature of equipment and connections, I've not yet attempted an SMC reset while the MagSafe was orange.
 
I have the schematic and the board view, though i'm not electrical engineer. I've followed V+ lines from both the battery and the DC in. all resistors test ok, all fuses are good. I'm showing 11.99VDC at each rail from the battery, at the connector.
 
Can anybody point me in a direction?
Can anybody point me in a direction?
 
PP3V3_S5 points:
 
[image|1098302]
 
PP5V_S5 points:
 
[image|1098303]

Устройство:

MacBook Pro 13" Unibody Early 2011

Статус:

open

Принятый ответ:

393172

Отредактировано: Ronnoc Nailli ,

Название:

no power to MacBook, new parts, other odd behavior

Текст:

I just received this A1278 EMC2419, MLB# 820-2936. I have very little history on it other than: MacBook stopped powering on, previous owner said they replaced:
 
* Battery
* MagSafe charger
* DC-in board
 
I can confirm the Chinese battery is new, the charger was still in plastic, but the DC-in board showed corrosion despite looking otherwise brand new and having a 2015 date stamp.
 
The MacBook doesn't respond to the power button, or to shorting the power pads. the MagSafe illuminates green with or without battery connected, and the battery level indicator is non-responsive *unless* the MagSafe is connected. I have attempted SMC reset, though I cannot be sure it has completed. I've shorted the pads at R5001 (omitted) which according to the internet will pull SMC_RESET low. That didn't have any apparent effect.
 
I set my SPI programmer with SOIC8 clip on the EFIROM, to attempt a reflash there, and strangely enough, the MagSafe turns orange when my programmer is connected and powered on. I'm unsure if that means the battery is charging, or that the SPI programmer is drawing current and tricking the MagSafe. Due to the precarious nature of equipment and connections, I've not yet attempted an SMC reset while the MagSafe was orange.
 
I have the schematic and the board view, though i'm not electrical engineer. I've followed V+ lines from both the battery and the DC in. all resistors test ok, all fuses are good. I'm showing 11.99VDC at each rail from the battery, at the connector.
 
Can anybody point me in a direction?

PP3V3_S5 points:
[image|1098302]

PP5V_S5 points:
[image|1098303]
Can anybody point me in a direction?

PP3V3_S5 points:
[image|1098302]

PP5V_S5 points:
[image|1098303]

Устройство:

MacBook Pro 13" Unibody Early 2011

Статус:

open

Отредактировано: Dan ,

Название:

no power to MacBook, new parts, other odd behavior

Текст:

iI just received this A1278 EMC2419, MLB# 820-2936. iI have very little history on it other than:

MacBook
MacBook stopped powering on, previous owner said they replaced:
iI just received this A1278 EMC2419, MLB# 820-2936. iI have very little history on it other than:

MacBook
MacBook stopped powering on, previous owner said they replaced:
* Battery
* MagSafe charger
* DC-in board
 
I can confirm the Chinese battery is new, the charger was still in plastic, but the DC-in board showed corrosion despite looking otherwise brand new and having a 2015 date stamp.
 
The MacBook doesn't respond to the power button, or to shorting the power pads. the MagSafe illuminates green with or without battery connected, and the battery level indicator is non-responsive *unless* the MagSafe is connected. I have attempted SMC reset, though I cannot be sure it has completed. I've shorted the pads at R5001 (omitted) which according to the internet will pull SMC_RESET low. That didn't have any apparent effect.
 
I set my SPI programmer with SOIC8 clip on the EFIROM, to attempt a reflash there, and strangely enough, the MagSafe turns orange when my programmer is connected and powered on. I'm unsure if that means the battery is charging, or that the SPI programmer is drawing current and tricking the MagSafe. Due to the precarious nature of equipment and connections, I've not yet attempted an SMC reset while the MagSafe was orange.
 
I have the schematic and the board view, though i'm not electrical engineer. I've followed V+ lines from both the battery and the DC in. all resistors test ok, all fuses are good. I'm showing 11.99VDC at each rail from the battery, at the connector.
 
Can anybody point me in a direction?

Устройство:

MacBook Pro 13" Unibody Early 2011

Статус:

open

Отредактировано: Dan ,

Название:

no power to MacBook, new parts, other odd behavior

Текст:

i just received this A1278 EMC2419, MLB# 820-2936. i have very little history on it other than:
 
MacBook stopped powering on, previous owner said they replaced:
* Battery
* MagSafe charger
* DC-in board
 
batteryI can confirm the Chinese battery is new, the charger was still in plastic, but the DC-in board showed corrosion despite looking otherwise brand new and having a 2015 date stamp.
batteryI can confirm the Chinese battery is new, the charger was still in plastic, but the DC-in board showed corrosion despite looking otherwise brand new and having a 2015 date stamp.
 
magsafe chargerThe MacBook doesn't respond to the power button, or to shorting the power pads. the MagSafe illuminates green with or without battery connected, and the battery level indicator is non-responsive *unless* the MagSafe is connected. I have attempted SMC reset, though I cannot be sure it has completed. I've shorted the pads at R5001 (omitted) which according to the internet will pull SMC_RESET low. That didn't have any apparent effect.
magsafe chargerThe MacBook doesn't respond to the power button, or to shorting the power pads. the MagSafe illuminates green with or without battery connected, and the battery level indicator is non-responsive *unless* the MagSafe is connected. I have attempted SMC reset, though I cannot be sure it has completed. I've shorted the pads at R5001 (omitted) which according to the internet will pull SMC_RESET low. That didn't have any apparent effect.
 
DC-in boardI set my SPI programmer with SOIC8 clip on the EFIROM, to attempt a reflash there, and strangely enough, the MagSafe turns orange when my programmer is connected and powered on. I'm unsure if that means the battery is charging, or that the SPI programmer is drawing current and tricking the MagSafe. Due to the precarious nature of equipment and connections, I've not yet attempted an SMC reset while the MagSafe was orange.
DC-in boardI set my SPI programmer with SOIC8 clip on the EFIROM, to attempt a reflash there, and strangely enough, the MagSafe turns orange when my programmer is connected and powered on. I'm unsure if that means the battery is charging, or that the SPI programmer is drawing current and tricking the MagSafe. Due to the precarious nature of equipment and connections, I've not yet attempted an SMC reset while the MagSafe was orange.
 
i can confirmI have the chinese battery is new,schematic and the charger was still in plastic, but the DC-in board showed corrosion despite looking otherwise brand newview, though i'm not electrical engineer. I've followed V+ lines from both the battery and having a 2015 date stampthe DC in. all resistors test ok, all fuses are good. I'm showing 11.99VDC at each rail from the battery, at the connector.
i can confirmI have the chinese battery is new,schematic and the charger was still in plastic, but the DC-in board showed corrosion despite looking otherwise brand newview, though i'm not electrical engineer. I've followed V+ lines from both the battery and having a 2015 date stampthe DC in. all resistors test ok, all fuses are good. I'm showing 11.99VDC at each rail from the battery, at the connector.
 
the MacBook doesn't respond to the power button, or to shorting the power pads. the magsafe illuminates green with or without battery connected, and the battery level indicator is non-responsive *unless* the magsafe is connected. i have attempted SMC reset, though I cannot be sure it has completed. i've shorted the pads at R5001(omitted) which according to the interwebs will pull SMC_RESET low. that didn't have any apparent effect.

i set my SPI programmer with SOIC8 clip on the EFIROM, to attempt a reflash there, and strangely enough, the magsafe turns orange when my programmer is connected and powered on. i'm unsure if that means the battery is charging, or that the SPI programmer is drawing current and tricking the magsafe. due to the precarious nature of equipment and connections ,i've not yet attempted an SMC reset while the magsafe was orange.

i have the schematic and the board view, though i'm not electrical engineer. i've followed V+ lines from both the battery and the DC in. all resistors test ok, all fuses are good. i'm showing 11.99VDC at each rail from the battery, at the connector.

can
Can anybody point me in a direction?
the MacBook doesn't respond to the power button, or to shorting the power pads. the magsafe illuminates green with or without battery connected, and the battery level indicator is non-responsive *unless* the magsafe is connected. i have attempted SMC reset, though I cannot be sure it has completed. i've shorted the pads at R5001(omitted) which according to the interwebs will pull SMC_RESET low. that didn't have any apparent effect.

i set my SPI programmer with SOIC8 clip on the EFIROM, to attempt a reflash there, and strangely enough, the magsafe turns orange when my programmer is connected and powered on. i'm unsure if that means the battery is charging, or that the SPI programmer is drawing current and tricking the magsafe. due to the precarious nature of equipment and connections ,i've not yet attempted an SMC reset while the magsafe was orange.

i have the schematic and the board view, though i'm not electrical engineer. i've followed V+ lines from both the battery and the DC in. all resistors test ok, all fuses are good. i'm showing 11.99VDC at each rail from the battery, at the connector.

can
Can anybody point me in a direction?

Устройство:

MacBook Pro 13" Unibody Early 2011

Статус:

open

Оригинальный сообщение: Ronnoc Nailli ,

Название:

no power to MacBook, new parts, other odd behavior

Текст:

i just received this A1278 EMC2419, MLB# 820-2936.  i have very little history on it other than:

MacBook stopped powering on, previous owner said they replaced:

battery

magsafe charger

DC-in board

i can confirm the chinese battery is new, the charger was still in plastic, but the DC-in board showed corrosion despite looking otherwise brand new and having a 2015 date stamp.

the MacBook doesn't respond to the power button, or to shorting the power pads.  the magsafe illuminates green with or without battery connected, and the battery level indicator is non-responsive *unless* the magsafe is connected.  i have attempted SMC reset, though I cannot be sure it has completed.  i've shorted the pads at R5001(omitted) which according to the interwebs will pull SMC_RESET low.  that didn't have any apparent effect.

i set my SPI programmer with SOIC8 clip on the EFIROM, to attempt a reflash there, and strangely enough, the magsafe turns orange when my programmer is connected and powered on.  i'm unsure if that means the battery is charging, or that the SPI programmer is drawing current and tricking the magsafe.  due to the precarious nature of equipment and connections ,i've not yet attempted an SMC reset while the magsafe was orange.

i have the schematic and the board view, though i'm not electrical engineer.  i've followed V+ lines from both the battery and the DC in.  all resistors test ok, all fuses are good.  i'm showing 11.99VDC at each rail from the battery, at the connector.

can anybody point me in a direction?

Устройство:

MacBook Pro 13" Unibody Early 2011

Статус:

open