Перейти к основному содержанию
Помощь

Текущая версия: aaronmabey ,

Название:

No backlight, new LCD and stuff

Текст:

So my phone took a bath a couple weeks ago. I took it home, pulled everything out of the case including the battery and let it sit in a bag of dessicant overnight. After reassembling the device, it powered on, but the backlight was out. Now this was a problem on and off before, since I replaced the back housing, but nothing was bringing it back to life. I ran it for a few days with no backlight which was annoying, but that's about it. A few days later, the whole display died and the phone wouldn't power on. So, I ordered a new battery, LCD, and #3 cable which had been buggy for months. I put it all in today, and now the phone powers on, and the display is alive again, but the backlight is still dead. I have checked every component on the logic board for signs of damage, including the display coil and all the connectors, but I can't find any obvious signs of damage. I have cleaned everything with alcohol, but I don't know what to think. The only thing that looks out of the ordinary is on the LCD connector on the logic board. The pins seem to flare out on the edge side of the connector. I don't have a picture to post, but looking at it in the housing, with the dock connector at the bottom, the right side of the connector pins are farther apart on the 2 rows than they are on the left side. Just slightly, but it could be enough to have a backbad connection on one side. I don't know which pins have the backlight signal, but I guess that it's possible that is why it's not coming on. Thoughts? Thanks ahead of time.
So my phone took a bath a couple weeks ago. I took it home, pulled everything out of the case including the battery and let it sit in a bag of dessicant overnight. After reassembling the device, it powered on, but the backlight was out. Now this was a problem on and off before, since I replaced the back housing, but nothing was bringing it back to life. I ran it for a few days with no backlight which was annoying, but that's about it. A few days later, the whole display died and the phone wouldn't power on. So, I ordered a new battery, LCD, and #3 cable which had been buggy for months. I put it all in today, and now the phone powers on, and the display is alive again, but the backlight is still dead. I have checked every component on the logic board for signs of damage, including the display coil and all the connectors, but I can't find any obvious signs of damage. I have cleaned everything with alcohol, but I don't know what to think. The only thing that looks out of the ordinary is on the LCD connector on the logic board. The pins seem to flare out on the edge side of the connector. I don't have a picture to post, but looking at it in the housing, with the dock connector at the bottom, the right side of the connector pins are farther apart on the 2 rows than they are on the left side. Just slightly, but it could be enough to have a backbad connection on one side. I don't know which pins have the backlight signal, but I guess that it's possible that is why it's not coming on. Thoughts? Thanks ahead of time.

Устройство:

iPhone 3GS

Статус:

open

Оригинальный сообщение: aaronmabey ,

Название:

No backlight, new LCD and stuff

Текст:

So my phone took a bath a couple weeks ago.  I took it home, pulled everything out of the case including the battery and let it sit in a bag of dessicant overnight.  After reassembling the device, it powered on, but the backlight was out.  Now this was a problem on and off before, since I replaced the back housing, but nothing was bringing it back to life.  I ran it for a few days with no backlight which was annoying, but that's about it.  A few days later, the whole display died and the phone wouldn't power on.  So, I ordered a new battery, LCD, and #3 cable which had been buggy for months.  I put it all in today, and now the phone powers on, and the display is alive again, but the backlight is still dead.  I have checked every component on the logic board for signs of damage, including the display coil and all the connectors, but I can't find any obvious signs of damage.  I have cleaned everything with alcohol, but I don't know what to think.  The only thing that looks out of the ordinary is on the LCD connector on the logic board.  The pins seem to flare out on the edge side of the connector.  I don't have a picture to post, but looking at it in the housing, with the dock connector at the bottom, the right side of the connector pins are farther apart on the 2 rows than they are on the left side.  Just slightly, but it could be enough to have a back connection on one side.  I don't know which pins have the backlight signal, but I guess that it's possible that is why it's not coming on.  Thoughts?  Thanks ahead of time.

Устройство:

iPhone 3GS

Статус:

open