Перейти к основному содержанию

Full Formated (even EFI)- Now I cant do anything


I have bougth an Asus zenbook UX32A. It had a Win 8 OS and i tried to install Ubuntu.

My problem. I didnt know anything about Uefi Bios systems and when I run the ubuntu install I erased ALL PARTITIONS and create only what I want (Like old School). Now the PC only boot on Bios, nothing more.

The problem, I think, is I erased the EFI Partition and now the UEFI dont work. How can I recovery the partition?

Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка 0
Добавить комментарий

2 Ответов

Выбранное решение

Hi Tonio,

If you want to do it hold fashion way, just inactivate the UEFI. Access your BIOS and on the BOOT page you should have possibility to disable UEFI.

To inactive the UEFI follow this step by step:

  1. Upon bootup press F2 to access BIOS Setup
  2. Go on BOOT page
  3. Select UEFI Boot Disable
  4. Also reconfigure the boot priority so that it point into the correct hard drive.

Block Image

Also, you should be able to recreate an EFI partition from ubuntu live CD/USB using GParted.

Hope this will work!

  • Massive edited due to I have been little speedy in my first reply and put wrong information. Sorry!

Был ли этот ответ полезен?

Оценка 3


Thanks so much!,

I did something like this but a little different jeje But this was an importat clue.

I dont have the option "UEFI Boot Enabled/Disabled", instead I haver two differents options:

- Fast Boot (In my case must be Disabled)

- CMD Boot (In my case must be Enabled)

Searching for the web found info about another option.

Security page -> Secure Boot (In my case must be Disabled)

When this option is Enabled booting from a device not signed for Microsoft is forbbiden!! (Dont know is correct, I understand this).

I disabled it and was able to boot from a USB with Ubuntu 12.10 64Bits (32bits distro DONT WORK for EFI). In the instalation I was able to create a 200mb EFI partition (i read 200 is recommended) and what i wanted for the OS.



Nice to see it work now! For information you should be able to activate the "fast boot" option. I had it working on my Asus with ubuntu 32 Bits version. This is great because your computer instantaneously boot the OS. Basically when you push power button you directly shows the OS loading screen. You save a few seconds and it's cool also!


Hi Gaetan,

I also formatted the entire HDD and lost EFI mode.

I have an Asus N56VJ and I want to recover my Windows License. How can I do it?


i have the same problem. how did u create a efi partition.. i get a secure boot violation error. on my asus ux32a.. pls help


Добавить комментарий

I have the same probleem after bios update.

Please help.

Был ли этот ответ полезен?

Оценка 0


I have a problem with my ASUS E403SA.

I tried to install another operating system after deletion of the previous one. Now, Microsoft OS can't be installed.

Instead, I get error message saying, partition was not created or system partition cannot be found.

Of late, I've got to realize that the BIOS EFI partition has been deleted.

Please, help me with a solution.


Добавить комментарий

Добавьте свой ответ

Antonio будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 0

За последние 30 дней: 17

За всё время: 8,632