Перейти к основному содержанию

Model M6497 or A1005 / 500, 600, 700, 800, or 900 MHz G3 processor

113вопросов Показать все
Вопрос закрыт

Airport card not registering, worked before?

This mac has worked fine for many years. Today it could not connect to the internet. The Airport card is not showing up. I swapped out the card with another (the card works in another machine), and same thing. The system profiler shows no card, even though I was very careful to seat it properly. Any ideas?

Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка 0
Добавить комментарий

2 Ответов

Выбранное решение

I'd reset the PMU also, since you didn't mention that. You've ruled out the Airport itself as the problem, which is good.

Take out the Airport, and with a flashlight, look down into the socket the card goes into. You will need to tilt the laptop upward so that you can see down into the slot, and it will still be difficult to see. What you are looking for are the two rows of metal pins...you want to make sure that all the pins are still straight, and that none of them have been smashed or bent (which can easily cause the problem you are describing). If you see any that are bent (usually on the ends), you will need to remove the top shielding in order to gain enough access to straighten them with tweezers. You can also just cut the visible section of the shielding off, although that is sloppier way to do it.

Also -- and this should actually be tried first -- as you know the Airport card plugs horizontally into a slot, and that slot itself is on a small card that plugs vertically down into the board. I've run into many cases in which the card gets slightly dislodged, causing the problem you've described. So, with the power off, use both thumbs to press firmly down on the area the Airpot card plugs into, in hopes that that will re-secure the slot itself to the board. Then re-install the Airport, cross your fingers, and power on.

The third possibility is that it's a software issue, so reinstalling the OS couldn't hurt, just to see.

The fourth possibility is that your board has gone bad in such a way that it can't see an Airport. I've seen it happen. But let's hope it's possibility 1-3. :-)

Hope that helps!


Был ли этот ответ полезен?

Оценка 2
Добавить комментарий

Reset PRAM for 3 times. If it didn't resolve it, reset PRAM for 5 times. Still the same issue, pull the keyboard out and take the Airport apart from its slot. Seat it back and put the keyboard back to its place. Now, turn on and see if this resolved. Please ground yourself while pulling Airport out.

If this helped you, please rate the answer. Thanks.

Был ли этот ответ полезен?

Оценка 0

1 Comment:

He's mentioned that he's already swapped the card out. And BTW, there is no functional difference between resetting the PRAM 3 times or 5 times.


Добавить комментарий
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 0

За последние 30 дней: 1

За всё время: 265