Перейти к основному содержанию

Model M7572 / 400 or 500 MHz G3 processor

Вопросов 46 Показать все

Typed real_mode in Open Firmware, Pismo won't start up.

I like to get help on this one.

I can not find the answer anywhere on the net so here it is.

A while ago I connected My Pismo to a PC in Target Disk Mode and after that the firewire port didn't work so I got into open Firmware and did the usual Reset nvram, set defaults, reset all commands,nothing after that but after I think using only reset nvram it worked but then My laptop got very slow (painfully) although processor time was idle (Odd),restarting and resetting with all 3 commands solved the slow response but then My firewire port didn't work again, also not showing up in System Profiler.

So I fiddled more in O.F. and typed in (I am almost sure it was the next command) setenv real-mode yes.

After this the pismo starts up but gives Me a black screen, no activity at all from the internal disk, yes it spins up but that's it,no read write I can hear.

It's not a hardware failure!

I tried resetting the Pismo with the reset button, got the battery out for a long time, also power off but to no avail.

I can Not get into anything, not even O.F.

If I hold the start button I get a few beeps and after keeping the button down it restarts and after a few seconds the display will light up but 2 seconds later it shuts of again.

Is there anybody knows what this (real-mode) command does and how to reset it?

Starting up from another internal disk with a clean OSX doesn't

work either.

Help please, cheers Perry

Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка 2
Добавить комментарий

Ответов (3)

Выбранное решение

Hi, First reset the computer. There is a button on the back next to the VGA connector--press that. If that doesn't work you may have a serious firmware problem but before deciding that's the problem I am including a Apple troubleshooting guide. Good luck Ralph


By the way your computer is listed as PowerBook g3 firewire. Ralph

Был ли этот ответ полезен?

Оценка 1
Добавить комментарий


Thanks for Your answer and I appreciate it but it's not what I am looking for.

I already did all of those things as I wrote in My question.

I do think do that you might be correct with you assumption that the firmware is corrupted.

And Yes, this is a Pismo PowerBook G3 with Firewire ports

Был ли этот ответ полезен?

Оценка 0

1 Комментарий:

My apologies - I missed your use of the reset when I read your post. This was however all I could find on your problem. There does not seem to be a command to restore firmware but if you go to the Apple site you may possibly be able to download a firmware update. I'm sorry I was not able to be of more help to you. Good luck. Ralph


Добавить комментарий

rj713 Ralph

Thanks for Your answer.

It eventually did solve My problem.

Not directly but You told Me to go to the Apple site.

So, I did and searched for the firmware update page.

Apple says its not really possible to update My firmware if the firmware release is the same but they tell You how to update a normal firware update.

I should boot into OS 9 and then restart holding both the Command and start button.

This of course didn't work since I could not boot it into any OS.

But, when I held both the start and Command button it started up right into open firmware, not the first time but the second time it did.


It probably reset the Open Firmware.

Thank for your answer.


Был ли этот ответ полезен?

Оценка 0

2 Комментариев:

congratulations perry - whil i googled around i've seen the postings from you on differend pages - glad that you finally could use your pismo again


I'm glad your problem has been resolved--good work. Ralph


Добавить комментарий

Добавьте свой ответ

justperry будет очень признателен(а).
Статистика просмотров:

За последние 24 час(ов): 1

За последние 7 дней: 1

За последние 30 дней: 16

За всё время: 2,494