Перейти к основному содержанию

Отремонтируйте ваше устройство

Обучение ремонту

Запчасти и инструменты

Model A1369, 1.6, 1.7, or 1.8 GHz Processor, 64, 128 or 256GB Flash Storage

354вопросов Показать все

New battery is not charging and condition says replace now?

I just replaced the battery on my Macbook Air 13" mid 2011, one I ordered from iFixIt and the computer recognizes it, but it says cycle count: 0 and condition: replace now.

I decided to replace the battery because it only got to 121 cycles before it stopped holding a charge at all and I could only use the laptop when plugged into the power adapter. The battery status says "Not Charging" and the adapter status light does not glow when connected (it does function normally when plugged into any other computer, so the adapter is not the issue). The second it becomes disconnected the computer shuts down.

Charge Information:

Charge Remaining (mAh): 2545

Fully Charged: No

Charging: No

Full Charge Capacity (mAh): 6620

Health Information:

Cycle Count: 0

Condition: Replace Now

Battery Installed: Yes

Amperage (mA): 0

Voltage (mV): 7575

I'm at a total loss for what to do next to solve this problem. Could it be the I/O board or cable? Any ideas? Thanks!

Отвечено! View the answer У меня та же проблема

Это хороший вопрос?

Оценка 5
Добавить комментарий

Nintendo Switch Kits

A quick fix to get back in the game

Shop Switch Kits

Nintendo Switch Kits

A quick fix to get back in the game

Shop Switch Kits

6 Ответов

Выбранное решение

If it came into my shop, I would replace the I/O board. Here's how to do it: MacBook Air 13" Mid 2011 I/O Board Replacement

Был ли этот ответ полезен?

Оценка 3

Комментарии:

OK, that seems to be the best option, so I'll try that next and update once done. Thanks for your input!

из

Добавить комментарий
Наиболее полезный ответ

I would like to add to this discussion. I have ordered 2 batteries from iFixit for a Mid2011 MacBook air and both are looking great with coconut battery....however :

1) Both are showing "Replace Now" in OSX

2) Both do not supply power to the system. When the power adapter is disconnected, the MacBook dies.

3) I have reset the SMC and PRAM.

4) I have tested both batteries in two different MacBook Air Mid2011's I have in stock which are in perfect shape and function normally.

5) Using other batteries I have in stock for these models, all batteries work normally. It's only the new ones supplied by iFixit that act this way (Show "Replace Now" in the OSX battery status and also will not supply power when the power adapter is disconnected)

6) Again, this happened with both MacBook Air's Mid-2011 I have here that are in perfect working condition.

I know this is an old thread. But I wanted to interject there might be something else going on besides a faulty IO board or Logic Board issue. There seems to be a compatibility issue with these batteries marked as compatible with this model.

Был ли этот ответ полезен?

Оценка 4

Комментарии:

@flux : Thank you so much. I have the same problem as you. The first Macbook Air mid 2011 battery ifixit send me wasn't working, and then they send me a second one --> the exact same problem as you described.

And my Macbook air works with the old battery perfectly fine, even though it just holds half of the original charge after 1300 cycles.

I tried everything to get the new one working, no chance. Could you figure out a solution? IFixit tech support has no idea, they send me the new one with the same problem. I am going to write them again now.

из

Hi Neven,

Yes. Try this...reset/re-calibrate the battery by :

1) Letting it run on battery until it is discharged and the mac goes to sleep on it's own. Basically set the power settings so the mac "never" goes to sleep. Then let it run on the new battery until it is fully discharged and the Mac goes to sleep due to low battery.

2) Then with it off...connect the mag-safe charger and fully charge the battery until it is full.

3) Fire it up and check status

This should hopefully reset the battery and re-calibrate the battery to the OS to get the OS to recognize it as healthy.

Let me know how it goes :)

Jason

Flux Computer

Portland OR

PS :

@neven Also I should mention the method I outlined above DID resolve the issue on my client's computer. It was NOT the IO board as originally suggested in this thread nor did I ever suspect the IO board. I thought they sent an incompatible battery but it was resolved with the re-calibration outlined in my comment above.

из

@flux

Hey Jason from Flux Computer :),

thank you for your reply. I wanted to reset/re-calibrate the battery as you outlined, but how, when the new battery won't supply power to the Mac.

As you wrote in your previous post, I have the same symptom:

"2) Both do not supply power to the system. When the power adapter is disconnected, the MacBook dies."

When I want to let the Macbook run on the new battery until it is discharged the mac immediately dies the moment I discontent the MagSafe from the Mac. The mac also doesn't want to turn on just on the new battery. I have to reconnect the MagSafe and then it will turn on, as if it did not have any power --> Time is reseted after log in and needs to update from server again.

So my question is, how can I re-calibrate the new battery to the OS, by discharging it, if the mac won't draw power from the battery?

Am I missing something?

Greetings from Germany

Neven

из

@neven Yes...sorry...It has been a little while since I dealt with this issue. I believe I got the computer to initially power off the battery by resetting the SMC a few times with the power adapter connected. I did this (reset the SMC) when the computer was booted into the OS. This is not good for the system or disk but I have had success in the past using this technique with other battery issues (rather than resetting the SMC with the MacBook powered off) to finally get the system to run on battery.

After this it would power off of the battery but the battery was still showing "replace now" and I believe would not charge from the mag-safe adapter. I then let it fully run down until it powered itself off and then fully charged back up with the mag adapter. After doing this, when fully charged, I booted the MacBook and it worked properly and was reporting as "Healthy" .

You might have to play with resetting the SMC a number of times while fully booted into the OS to get this to work.

из

After the procedure...and after you get the battery working again...you should go into single user mode and do a file system check (/sbin/fsck -fy) to repair any damage caused by the sudden shutdowns while in the OS. I'm not certain what is causing this issue in some cases but This procedure resolved it.

I should stress again that the battery did the same thing (had the same problems) in 2 other shop MacBooks of the same model and it happened with the 1st new battery sent by iFixit and the 2nd replacement new battery...on all machines...so the issue is with the build of batteries being supplied to iFixit. Why more people are not having this issue is a bit of a mystery to me.

Good luck!

Flux

из

Показать 7 больше комментариев

Добавить комментарий

@neven

Sounds good. I assume you have also reset the PRAM during your troubleshooting? Sorry it didn't work for you. Yes...it's quite frustrating. The other option is using a different supplier for your battery completely or going for a used battery from iFixit to see if that gets you by. Good luck and if you get it sorted out please drop a note on this thread.

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

Unfortunately, even though this is a four year old thread now, and I hate posting in it, but, it seems to still be happening, and I cannot get the system to run from the battery no matter how much I reset the SMC from the OS or even when powered off. I’m guessing the bad iFixit battery issue has reared its ugly head at the end of 2019. Are there any other ways to attempt to correct the battery condition, or do I just need to try and get a new replacement battery? Its a late 2011 macbook pro. And yes, I even reset the PRAM attempting to fix this. I did get it to not recognize the battery entirely once, but then it just went back to not running from the battery like before after another SMC reset.

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

I replaced my MacBook Air battery after the battery wouldn’t charge. It worked fine for a few days and now the new battery won’t charge. I am not sure what to do. 2013 model

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

Can you please help me I installed the battery into my macbook pro 2014 a few months ago and everything was fine and now it's only operating at 50% capacity and i'm getting less than 4 hours life on it. I have tried a battery calibration, a SMC and a PRAM reset and i still get a "service recommended" warning on the battery

Can you help me please?


Был ли этот ответ полезен?

Оценка 0

Комментарии:

Hi hjmma ,

Try downloading Coconut Battery and see if it is showing an issue with the battery as well. It could be a hardware issue or a battery issue. Make sure the battery connector ribbon is fully seated in the connector on the board and the retaining flap is down on the connector. That's where I would start.

из

@flux I have done that and yes it is fully connected

из

...and what did Coconut Battery say as far as condition?

из

@flux It says check battery and that it's 50% design capacity. full charge capacity is literally half :(

из

Based on that my guess would be you drew the short straw on the Silicon Lottery and purchased a defective battery with a short life before failing. It happens. I've seen situations where OSX says check/replace battery but Coconut says it's fine and in those situations I would be looking deeper but if both say bad battery I would lean toward an actual bad battery. I could be wrong but that would be my guess. Bummer because I know the glue is a pain for install/removal.

из

Показать 2 больше комментариев

Добавить комментарий

Добавьте свой ответ

crystalh будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 12

За последние 7 дней: 66

За последние 30 дней: 296

За всё время: 22,804