Перейти к основному содержанию

Отремонтируйте ваше устройство

Обучение ремонту

Магазин

2.26 or 2.4 GHz / White plastic unibody enclosure

752вопросов Показать все

Can't use boot modifiers

Here's a strange one for you guys.

I just picked up a used MacBook that I'm working on refurbishing for sale. The trackpad needed to be replaced, so I took care of that. I also upgraded the hard drive and RAM (came with 2 GB upgraded to 4 GB). After all that was done, I went to format the HD and install a fresh copy of Mavericks. Strangely enough though, my usual method of holding down the option key at startup so I can select my Mavericks USB install drive did not work. When I tried, it just booted up normally. So I changed the startup disk in System Preferences and did the format and install figuring that maybe the problem would resolve itself with a fresh copy of OS X. Unfortunately it did not. I tried to reset the PRAM, and discovered that I am not able to do that either. In fact, when resetting the PRAM, it boots into recovery mode, so it is at least recognizing that I have the R key held down.

At this point, I started to explore the idea that the keyboard could be faulty. I first tried to use an external keyboard and saw no changes in behavior. Then I booted the machine and tested each key. No issues with any of the keys responding. So I don't believe that it's the keyboard.

Other troubleshooting that I have done:

- Checked to see if there was a firmware password set, There was not. I enabled a firmware password, rebooted, and removed it just to be sure that it was off.

- I tried installing the original RAM that came with the machine. No changes.

- I tried installing other RAM, both 1 and 2 GB SODIMM's, again, no luck.

So anyone have any suggestions? If it's not the keyboard, there isn't a firmware password, and it's not the RAM, what in the world could be causing this??

Thanks!

Отвечено! View the answer У меня та же проблема

Это хороший вопрос?

Оценка 0

Комментарии:

I wanted to add that I reset the SMC just in the off chance that would have an effect. Although this did not solve the problem, it did confirm for me that the problem is not the keyboard, because when I reset the SMC the MagSafe adapter changed from amber to green.

из

Another small development...it does allow me to boot into safe mode by holding down the shift key. This should confirm that there is no firmware password, since if there was once enabled, I would not be able to boot to safe mode as per this Apple support document:

http://support.apple.com/kb/ht1352

из

This could be unrelated...or it could be the cause somehow...but I just figured out that one of the two USB ports on the machine is faulty. So perhaps there's something wrong with the USB Bus on the logic board that is preventing it from seeing the internal keyboard during the boot process? I tried again with an external keyboard plugged into the known good USB port, but that still did not work.

из

Добавить комментарий

2 Ответов

Выбранное решение

I would remove the target HDD from the case, put it in an enclosure, plug it into my MacBook Pro, then examine it using Disk Utility. I'd look for odd partitions for example, the sort some people cause when they install Windows on a Mac using 3rd party software instead of Boot Camp, or partition the HDD from Boot Camp, etc. that could be causing issues at the HDD level.

At this point, it would be possible to verify/repair and plug back into the old Mac. But why bother?

I'd format it and restore a working OS from the source HDD plugged into another USB. Then run verify/repair and permissions to check everything is ok.

Then install in the old Mac, restart, and test.

That's my thought..

Был ли этот ответ полезен?

Оценка 2
Добавить комментарий

Yes, very odd...

How about checking the firmware. Follow this Apple TN: EFI and SMC firmware updates for Intel-based Macs.

Был ли этот ответ полезен?

Оценка 1

Комментарии:

Thanks for the suggestion, but the 2009 Unibody MacBook is not on that list, meaning that they never released a firmware or SMC update for this machine. Also, no firmware updates come up through software update.

из

Добавить комментарий

Добавьте свой ответ

iGuys будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 1

За последние 7 дней: 3

За последние 30 дней: 8

За всё время: 657