Перейти к основному содержанию

Released on October 23, 2012. Core i5 or Core i7 Processor. Apple Fusion Drive.

209вопросов Показать все

Samsung 840 EVO - can't erase / partition

After installing the Samsung 840 EVO SSD exactly as per the instructions, I booted up the MAC MINI and the drive was visible, but needed formatting to OSX extended (journaled) in order for me to then install OSX on it and then migrate the old HD system and apps to it.

However, when I try formatting the 840, I keep getting a formatting error:

Disk Erase failed with the error:

File system formatter failed.

1. I can see the EVO drive in the MAC's Disk utility app with a sub partition named disk1s2 greyed out.

2. I click on the main drive image - 500.11GB Samsung SSD EVO 500GB Media, I have the option to erase or partition.

3. I try partitioning it into a single partition with the options set to GUID partition table format, I get the above error.

4. The option of re-partitioning the disk1s2 partition is greyed out and not available, only erase for which I get the same error above.

5. The Samsung MAGICIAN utility is'' Windows only''bold text (How dumb!)

6. I do have a PC/windows laptop available, so do I need to go through all the hassle of pulling out the SSD from the MAC MINI and using the Windows only MAGICIAN utility to reformat the drive or is there an easier way?

And even if I do, won't I be just back where I started?

Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка 1
Добавить комментарий

Ответов (3)

Выбранное решение

While I haven't tried this it should work: Setup your system in Target Mode and then connect it to your Windows PC system running Samsung's Magician software.

Or down load their image file for Mac onto a USB drive (Linux) and run it that way.

I suspect you got a returned drive. Where did you get it? Did you know it was an open box unit?

We have quite a few 840 EVO drives and have not needed to do this (we just upgraded 20 systems).

Don't forget to enable TRIM under the latest version of Yosemite, it makes a big difference!

Был ли этот ответ полезен?

Оценка 1

3 Комментариев:

I twice had a similar issue.

First case solved by first erasing the partition (say Rany's SSD), then erasing the main drive (say Macintosh HD), then partitioning the main drive.

Another time, had to add a partition, install OS X on it, boot, then from there erase/expand. Was sometime ago, not sure about the details, so hope it makes sense...


Wreaking.....do you mean re-formatting / partitioning etc?


@David Yowell, sorry typing mistake... I meant "erasing."


Добавить комментарий

So do I connect the Mac Mini to the PC via ethernet / wifi?

Should the Magician software already be running before trying to network / connect them?

Forgive me, but I always thought that networking macs and PC's together is a bit of a mind bender...or is that now a thing of the past?

Also I saw an article saying that there are reported firmware issues on the 840 EVO

(Mine is brand new in an un-opened box but I bought it about a year ago and didn't get around to installing it until now):


The article recommended updating to the latest SSD drive firmware by downloading an iso archive from Samsung and then changing the file name to have a .dmg extension,

burning a disc image of it,

then rebooting the Mac Mini using the the resulting DVD-R, to install the firmware update,

which I tried and it seemed to go through all the steps, albeit in a DOS/Linux window, but when I looked at the firmware version it hadn't updated.

I have also tried every possible combination of Mac recommended drive formatting / partitioning in Disk utility - Mac OS extended, FAT and EXFAT as well but still no joy (is that what you mean by "Wreaking" Rany?)

It sees the drive but mostly throws up an error message when trying to format.

A couple of times, it even seemed to format successfully, but when I tried testing the mounted drive by copying a file any bigger than around 10Mb, it would just go into an endless file copying progress bar.

What and unfriendly and primitive service that Samsung are offering for Mac users!

I'm thinking I might just pull the drive back out and ditch it, then buy another from a more Mac friendly manufacturer.

Any suggestions?

Был ли этот ответ полезен?

Оценка 0

5 Комментариев:

Yes! To your first Q - You're connecting the Mini as if it were an external drive via USB or Ethernet. The Windows system see's it like a standard drive. Just don't format the disk! All you want to do here is run the Samsung Magician software to install the update firmware and delete the partitions. You need to have it seen by the system first before you run the software.


We always used the boot image method by burning a CD. Samsung image file uses Linux to boot up and then runs off of it. Which is how we first installed the drives a year ago. And Yes, it's a pain! As you don't have a CD drive internally in your Mac Mini I figured you could try the PC method. Since you've moved past that hurdle, it sounds like you my have a second problem here. Do you have an external USB case to install the SSD in? I think you'll need to take it out and use the external connection to double check things here. If it works externally that points to a damaged or bad SATA cable. Lastly, I would also double check your systems firmware. Follow this Apple T/N: About EFI and SMC firmware updates for Intel-based Mac computers.


I wouldn't throw the baby out with the bathwater yet! As I stated we have quite a few in use. There a good drive and to be frank, I haven't seen any 3rd party SSD manufacture thats better here. They all have warts in some way or another. - Hang in there! let us know if the drive works better externally and if you needed to upgrade the systems firmware.


Ok just had a reply from Samsung support and they reckon it's due to the poor quality cable!


But I will try what you say anyway.


Добавить комментарий


did you get your problem resolved in the end ?


Был ли этот ответ полезен?

Оценка 0

4 Комментариев:

@Spa - As this is an old thread how about creating a fresh question describing what you're encountering. You may have a different problem than what David had. His I'm sure was a bad SATA cable at the end of it.

Samsung drives don't need to use the Magician software unless the low level format has been damaged. FYI we have hundreds of Samsung SSD's in use in many different Mac's. Only had one failure out of the box and all are still working!


Hi Dan,

thanks for your reply.

I've isolated the problem, the SSD works fine directly in place of the HD. I used El Capitan on a USB stick to install the OS.

The problem is :

1) Caddy

2) Cable from MB to caddy

3) the SSD does not like being plugged into the super drive SATA connection.

Before I started the superdrive wasn't working, so it may be 2)

Not sure. The HD is slightly too thick to fit into the caddy, by about 1mm.

So at this time the I only have a 250GB Samsung 850EVO ssd in the MBP.

I'll get a new caddy and see if it is any better, perhaps I can fit the 500GB HD in a different one. That will be ideal. Otherwise I'll try and get hold of another short cable connector.


@Spa - Sadly, I think you hit a known issue here. Review this: OWC Data Doubler jump to the very bottom and read the Red note. Your issue is not the SSD, or the carrier it's the system its self!

You'll need a FIXED SATA II (3.0 Gb/s) drive here. The Samsung drive won't work as the Auto SATA port sense technology it has can't figure out what the port speed is. This is also true with any other auto sense drive (SSD or HD).

The rub here is the ports speed is not SATA II or SATA III but some where in-between, thats why you need a fixed speed drive.


Dan, many thanks for the link. Hmm,worst case scenario. I need to decide if I need that extra capacity internally or just install the HD into an external case and use it on USB2.


Добавить комментарий

Добавьте свой ответ

David Yowell будет вечно благодарен.
Просмотр статистики:

За последние 24 час(ов): 0

За последние 7 дней: 4

За последние 30 дней: 11

За всё время: 6,266