Portable drives do not show up after using Sabrent USB Hub

I bought Sabrent USB Hub. I had it connected to my husband's laptop, with all 4 2TB portable drives hooked up to it. It worked great. But when I tried to disconnect it, it was only showing #1. The other three were greyed out. So, I finished doing my work, so nothing was being used. I disconnected it, but it wouldn't allow. I pushed blue power button on each usb connection, and shut things down. But now, I plugged in the sabrent to my desktop and it shut down my computer. Just hard shut down. I unplugged it from the usb to the desktop. And now it wont show any of the drives at all. I plug them in, and they arent in device manager, nothing. I even installed Easeus and it doesnt see any of them either. In device manager, nothing has an exclamation point. But at the same time, none of the drive show up. All 3 have lights on them. But they don't do a thing. No clicking. Only the 4th one still works. I have over 6TB worth of stuff on these.........UGH!!!!!!!

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 0
Добавить комментарий