Перейти к основному содержанию

Released June 2012 / Core i7 processor with Turbo Boost / Up to 1 GB DDR5 Video RAM

560вопросов Показать все
Вопрос закрыт

Multiple MagSafe Board Failures

Hi all.

I have a MacBook Pro 15" Unibody mid-2012. I have two 85w power supplies that I use interchangeably. One stays at my desk at home and the other travels with me.

While using the 'travel' charger the other day, I heard a pop (I think from the charger/brick) and the charging indicator light wouldn't light up. The MacBook showed it was running from battery. I unplugged it immediately but was in the middle of something important continued working since I showed I had 95%-ish battery remaining. At around 45% I had completed my tasks and went to plug it in using the 'desk' charger. The charge light wouldn't light up and the on-screen indicator showed that it was running only from battery. The desk charger still works on an older MacBook Pro I have, so I can see that the charger works fine.

After some diagnosis I believed the MagSafe board had gone bad. I bought one from Amazon and installed it.

It worked! At this point my Mac's battery was at 1%, so I left it closed in sleep mode and charged it until the charge indicator on the power supply went green. I left it closed and didn't touch it. About 30 minutes later, I heard it restart on it's own. At this point, the light on the cable wasn't on anymore. It was still plugged in. I opened it and let it boot with the charger still attached. It showed it was running from battery only and wasn't charging. I used it long enough to run a backup and I'm down around 40% before shutting it down.

All signs seem to point to a bad MagSafe board again. The desk charger still works with other MacBooks. I've ordered a second replacement MagSafe board that will be here in a few days. I'm concerned that the problem will present itself again. What else should I be looking into? Battery? Logic board? Gremlins?

Thanks for your replies! I'll do my best to post updates and answer any questions.

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 0


Update - I received the second MagSafe board and installed it. The charge indicator light on the cable didn't light up at all. I did an SMC reset and still nothing. I'm still tinkering. Any ideas you may have are greatly appreciated!


Добавить комментарий

1 ответ

I had a MacBook Pro once that had a similar problem. Doing the typical resets actually fixed it. The person I bought it from said it had a bad battery. When you plugged it in, nothing, no charging, light was green. Hit Shift+Control+Option+Power, let it sit for five seconds, with the cord plugged in, then reset the PRAM by holding down the power button til you see the light flash then when you hear the chime hold down Command+Option+P+R. If you do that right, it will restart, Do that three times.

I saw you said you did the SMC reset. Sometimes you have to do all three resets. Might work, might not, on another one it did not. Could also remove the logic board and see if something is caked on the backside or near the battery or MagSafe port. I tear a lot of these apart and it can be several things. Sounds like your on the right track though!

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 0

За последние 30 дней: 0

За всё время: 123