Перейти к основному содержанию

Model A1502 / 2.4, 2.6, or 2.8 GHz dual-core Intel processor / Released October 2013

554вопросов Показать все

Having keyboard & trackpad problems

I have had this problem since August. It is incredibly annoying. I can tell it is a software problem because I watch it happening when I boot the machine with verbose logging. I can't fix it myself because the files I would have to edit or replace have been locked by Apple.

I filed a bug report in at the Developer support forum in August 2015. At the beginning of December, I got my first response: Would I please do a sysdiagnose and attach the report to my response? So I did. Then they wrote me and asked me to do it again with the backup volume attached. So I did that.

I have yet to get any real help from Apple, and the internal trackpad problem persists. I use OSX 10.11, and all my software is up-to-date. There is a Firmware update designed for this specific machine and this specific problem, but when I try to install it, I get an error message and am unable to complete the installation. I have tried a variety of alternate trackpad-equivalents, none of which have worked. It is very frustrating.

Update (01/02/2016)

Here's the Apple Update page with the info about the Trackpad update: Trackpad Update 1.0

These are good questions. Here is the info on my mac:

  • MacBook Pro (Retina, 13-inch, Late 2013
  • 2.8 GHz Intel Core i7
  • 4 GB 1600 MHz DDR3
  • Boot ROM Version: MBP111.0138.B15
  • SMC Version (system): 2.16f68

RE: verbose logging, I'll fill in more details when I can take a screenshot, but here is a recent console log w/some info:

D[BNBTrackpadDevice::getExtendedReport][90.3] ERROR: [BNBTrackpadDevice] getReport returned error e00002d7 for reportID 0x0047

Dec 28 21:00:01 SCWHD-2 kernel[0][BNBTrackpadDevice][updateBatteryLevel] Couldn't get battery percentage from device

Dec 28 21:00:01 SCWHD-2 kernel[0]: [BNBTrackpadDevice][waitForData][70-cd-60-fb-ab-57] Became inactive waiting for data.

Yes, I have spoken with Apple. My machine is no longer covered by warranty, so no help has been provided.

Update (01/02/2016)

I have not taken it to the Apple store, however I did have a long talk with a senior technician about it.

The error message I get is something to the effect that "this software cannot be installed on your computer." That's after I launched the installer and had gone through all the pre-installation windows.

Here is a link to a page on the Apple site that describes the exact problem I am having. Unfortunately, none of the easy solutions, like running disk utility or fixing the file permissions has made one iota of difference.

FWIW, I am getting some truly exotic error messages via the console. To wit:

"TOCGenerator[520]: WARNING: The Gestalt selector gestaltSystemVersion is returning 10.9.0 instead of 10.11.0. This is not a bug in Gestalt -- it is a documented limitation. Use NSProcessInfo's operatingSystemVersion property to get correct system version number."

I am grateful for your interest and help!


Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка 0


Have you brought your system into an Apple Store to show them the problem?


What is the exact error you get when you try to run the update for the trackpad?


You state you have spoken to Apple Did you visit an Apple Store and show them the problem? If you did what did they say?


This post on the Apple Support site is a near-perfect characterization of the problem I'm having. Interesting, too, it appeared right after I installed Yosemite (OS X 10.10.5). I had hoped that replacing that with "el Capitan" would rectify the problem but it did not.


As of this morning, I can finally return to report success. I believe the problem I had was due to both hardware and software problems. I ended up having to wipe and rebuild my hard drive. The keyboard then started working but the trackpad did not. When I ran a variety of system tests, I was still getting that same old error message about its "legacy driver." In total frustration, I decided to replace the upper case, to make sure the keyboard and trackpad were in reliable working order. I just completed that task, thanks to an amazing ifixit repair guide (or three)! Now, the (internal USB) keyboard and trackpad work. I feel like I have a new machine - no thanks to Apple, but with abundant thanks to ifixit!


Добавить комментарий

1 ответ

Выбранное решение

I had a very similar problem and almost sent it into Apple until I accidentally solved it. See my question and answer here: Trackpad Does not Function Properly

Был ли этот ответ полезен?

Оценка 3


I had a feeling it was the same issue you had faced before Mayer.


Dan, I spent about 20 hours trying to solve this, real nasty problem.


Wow - thanks! This looks really promising. I will give it a try and let you know how it goes. In the mean time, it is a great relief to learn that someone who really knows these machines struggled to find a solution. I've been trying to do so since the disastrous introduction of Yosemite (10.10.5) in August.

Stay tuned.



@saraw1 - Please post a link in the Apple Developers dialog you have running now to your question here. That way others (Apple them selves) can track what is needed here to fix the problem. I suspect the firmware updater needs to be patched so it runs under the newer OS's.


Will do, Dan. By Wednesday, I'll have a new, clean backup drive and will proceed to implement @mayer' s recommended solution. I'll also add that link, and will keep you posted. Many thanks! Sara


Показать 6 больше комментариев

Добавить комментарий

Добавьте свой ответ

Sara Wedeman будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 7

За последние 30 дней: 27

За всё время: 12,978