Перейти к основному содержанию

Won't boot - question mark appears.


I hope someone can give me some advice.

I'm trying to repair a 12" Powerbook G4.

When turned on, it chimes and eventually shows the smiley face with a question mark.

I believe this usually means it can't find an operating system.

I tried booting with an an OSX install disc holding down the "C" key as the computer boots.

The CD whirrs and clicks for about a minute then it gets ejected.

I tried with another OSX install disc, the original software disc that came with the powerbook and the hardware test disc too. They all get ejected after about a minute.

I got a known good int HD and replaced the harddrive, but got the same problems.

I've reset the PRAM using the four keys.

So, any ideas? Is it time to let it rest in pieces?!



Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка -1
1 Комментарий

+ nicely started question


Добавить комментарий

Ответов (4)

Выбранное решение

Hi Mayer,

Thanks for the reply.

I didn't know you could boot from an external drive!

I'm off to find an firewire drive to try it.

Getting my hands on an ext. firewire DVD might take a bit longer.

I'll report back any results.

Thanks again for the response, much appreciated.

Был ли этот ответ полезен?

Оценка 0

1 Комментарий:

OK, I got access to a G5 and the little powerbook DOES boot from a firewire drive!

But, I opened disc utility and the only drive it sees is the firewire drive. It doesn't see the internal HD nor the optical drive.

Does this mean the end for the powerbook?

I'm certain the cable from the int drive is well inserted!

Any thoughts or advice?

Many thanks.

And one other thing, I did remove the third party RAM just in case it was the culprit, but it wasn't.


Добавить комментарий
Наиболее полезный ответ

You've done the right test procedures. I would next try booting from an external firewire drive. Then an external DVD drive.

Был ли этот ответ полезен?

Оценка 3

2 Комментариев:

Not going so well!

I finally got a firewire drive.

Trying to load OSX on it is proving interesting!

My main mac is a macpro.

If I put in an 10.4 disc, and run the install it thinks I'm loading it onto my macpro and won't give me an option to load it on another disc.

I found a 10.5 disc, which does give me the option of loading onto the external drive.

BUT, the drive needs formatted, and I get 3 choices. I'm trying to use the option that will allow the disc to be used as a boot disc for a powerPC mac, which would suit the powerbook. But when I try to install the OS, it tells me the disc must be formatted as a Intel boot disc (GUIDO I think it was called).

So, I've spent a lot of time getting nowhere!

As an educated guess, if the little powerbook won't load from a known good internal HD, nor it's optical drive, I guess the chances of the fault being easy to fix, and more importantly cheap to fix are slim?

My unqualified mind is thinking it's probably a logic board, and therefore beyond economical repair?


Добавить комментарий
Этот ответ изначально был на другой вопрос.

I didn't see anywhere a suggestion for replacing the logic board. If it boots from the G5 installed system external firewire drive, use that drive and install it. If it's a 3.5" drive clone it.

First boot from the external and go to "about this mac" and see if the internal hard drive or optical drives are seen. If not, replace the internal drive, boot from the external and use SuperDuper to clone it after you have formatted it. http://www.shirt-pocket.com/SuperDuper/S...

I do not see a guide to replace the hard drive specifically but this guide will get you there: PowerBook G4 Aluminum 12" 867 MHz Logic Board Replacement

Был ли этот ответ полезен?

Оценка 2

3 Комментариев:



Many thanks for your answer.

I had already tried a different drive in the powerbook at the start, and was told it was a bootable drive with OS X on it, but it now looks like it wasn't!

I replaced the drive with a new drive today (following your last answer) and I'm delighted to say I've got the little thing working again. The optical drive is still dead and ate on of my discs, but the optical isn't too important.

Thanks again for your advice. Much appreciated.

PS There is a guide to replacing the drive on the powerbook (luckily I'd saved it as a bookmark - http://tinyurl.com/yca8bsy - but for some reason the title has been changed to something about a master password?

Great site this!!


It's great when we can work through a difficult problem and get a success! Come back anytime ;-)


Добавить комментарий

They all get ejected after about a minute.Toshiba satellite m40 batteries

I got a known good int HD and replaced the Toshiba satellite m45 batteries harddrive

Был ли этот ответ полезен?

Оценка 0

2 Комментариев:

I tried with another OSX install disc,Toshiba satellite m55 batteries the original software disc that came with the powerbook and Toshiba satellite p205 batteries the hardware test disc too


Where did this come from? What Toshiba batteries? If this is a new question, please post it as such. You have me totally lost.


Добавить комментарий

Добавьте свой ответ

kwackman будет очень признателен(а).
Статистика просмотров:

За последние 24 час(ов): 0

За последние 7 дней: 0

За последние 30 дней: 6

За всё время: 3,278