Перейти к основному содержанию

Model A1181: 1.83, 2, 2.1, 2.13, 2.16, 2.2, or 2.4 GHz Core 2 Duo processor

1203вопросов Показать все

Off AC goes to sleep, can't wake.

If my MacBook is taken off the charger and is turned on, the battery runs down and goes to sleep; like it should. When I try to turn it on again, it won't come out of sleep mode.

I can push and hold the power button until it turns off and when I press it again, I hear the typical CD drive check and if I put me ear to the wrist rest, I can hear the HD spin up, but not read.

I have tried the various resets for PRAM, PMU, remove the battery/AC hold power button, reseat the RAM, etc. and nothing seems to be working. I had this same problem a month or so ago and I was able to somehow resurrect it. I told my wife to always make sure and leave it plugged in if it is on so we avoid the problem, she forgot that it was on last night and here we are today.


Update: I ordered a PRAM battery off eBay that supposedly is good. I put it into my MB and nothing has changed. I did find however that when I push and hold the power button that the sleep mode indicator has an unusual flash pattern. Does anyone know where I can look up flash patterns and what they mean?

Anyone have any suggestions as to what my problem may be?

Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка 3
3 Комментариев

Mayer; that seemed to work. I popped one stick out, tried both slots and nothing, I popped the next one in and voila, its been resurrected. So does that mean I have a bad RAM stick?


It's either a bad stick or a bad slot or your not getting it seated properly.


Well thought out question +


Добавить комментарий

3 Ответов

Выбранное решение

Once your battery runs all the way down on this model it won't restart till it has about 20-30 minutes worth of charge with the battery in. You can remove the battery and it will run or just plug it in, hit the start button and walk away. As soon as it's charged enough it will boot on its own.

Был ли этот ответ полезен?

Оценка 2

3 Комментариев:

I've tried that. The battery shows it is on its last leg of the charge, probably 95%+ charged.

I also removed the battery several times and it will not run.


UPDATE The flashing is most likely a RAM code. Remove both sticks of RAM and replace them one at a time, each stick in each slot, restarting each time. You may have a seating problem, a bad stick or a bad port.


Good answer +


Добавить комментарий

Check keyboard connector

I think if you removed the top case then when you reassembled it you did not get the top case connector on straight or properly. If the ribbon cable is not connected pushing the start button will accomplish nothing.

If this answer was helpful please remember to mark it accepted.

Good Luck,


Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

Machead: I never took anything apart. I only removed the battery. The power button turns on the computer, but it doesn't go anywhere. As stated above, I had this problem once before and I was able to eventually get it out of its stuck sleep mode. I just don't know if there is another way to properly do it.

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

Добавьте свой ответ

Jimmy будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 0

За последние 30 дней: 1

За всё время: 2,493