Перейти к основному содержанию

Отремонтируйте ваше устройство

Обучение ремонту

Магазин

Works fine until a battery is connected, then shuts off

Hi All! I've got an A1138 PowerBook that works fine on AC power with no battery attached, but when I connect a known-good battery (I've tried several known-good batteries), the machine immediately shuts off. The AC adapter light, which glows bright green without the battery in, goes out completely and erratically flickers amber when you connect a battery. The machine won't power on with a battery in except occasionally, and quickly goes off again. Again, this all happens when a battery is connected, and without a battery, everything's fine. My first guess was the battery connector, but I replaced that with no change. Next up was the DC-in, and I tried 3 I had sitting around, although I think they all may be flaky to some degree, so I'm not confident I've properly ruled out the DC-in. I've got a good DC-in on the way, but I'm not sure that's the problem...this seems more like a short, or an electrical issue. Any ideas? I know it's not the RAM, AC adapter, resets, etc. Thanks!

Отвечено! View the answer У меня та же проблема

Это хороший вопрос?

Оценка 3

Комментарии:

Got the replacement DC-in, and no luck. It behaves exactly like the other, which is perfectly, until you add a battery, and then the machine shuts off, and the AC light glows off and on amber.

из

Добавить комментарий

1 ответ

Выбранное решение

OK, this is a shot in the dark. Disconnect the battery connector cable from the logic board and insert a battery to see if it's physical.

Был ли этот ответ полезен?

Оценка 4

Комментарии:

Without the battery connector nothing happened. Good idea though!

из

Sounds like a logic board to me. You guys have such interesting problems. + to both.

из

Добавить комментарий

Добавьте свой ответ

rdklinc будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 0

За последние 30 дней: 0

За всё время: 2,129