Перейти к основному содержанию
Вопрос закрыт

Why do videos stutter online?

One of my many laptops is a Toshiba Satellite L305D. It's old but it's my favorite. It does everything I need it to. I also run windows xp, and I am perfectly happy with it despite the security vulnerabilities. I've no intention of upgrading the laptop or operating system in the foreseeable future (I own newer operating systems and newer laptops, but this is my preference).

The laptop has one drawback - it stutters during playback of videos on youtube. If I move the cursor around the screen while a youtube video is playing or try to do anything else, the stutter gets much worse.

So, I was bored the other day, and decided I was going to solve the mystery once and for all; but to no avail.

The L305D was packaged with Vista, so the first thing someone is going to think is "oh it's your drivers". I beg to differ. A great deal of effort went into finding sufficient drivers that would work for xp, and the system runs fine. When I play a video that is already saved to my computer, I can move the cursor around and open up any number of programs and there is no stutter.

So out of curiosity, I backed up my files and reformatted the harddrive and temporarily installed windows 7 just to see. Does the same thing and those drivers are microsoft certified. It's true that I have never installed Vista, but I've a sneaking suspicion that it would do the same as well.

So, back to my trusty XP installation. I read a great deal on how this was a problem with google chrome - so, I tried youtube with firefox. Same thing happens. I tried it in internet explorer. Same thing happens.

So maybe it's just youtube? Nope. I went over to dailymotion and the exact same thing happens when I play a video. I would conclude therefore that the problem does not lie within the browser or in the particular video host.

I'm led to believe this is an issue somewhere in the laptop; I just don't know where. As I said, songs play fine, and videos play fine that are downloaded to the laptop. The internet connection is just fine, as I can play online videos just fine from my roommates laptop - so it's not an issue with the internet.

Keep in mind that installing windows 7 did not resolve the issue, so I don't believe it has anything to do with the operating system. Now, many people deride the L305d for having a low quality graphics processor which shares system memory - however, if this were the problem I'm having, why then would it not present itself when playing a video already saved to the hard drive? This would seem to rule that out.

Codecs, I do not believe to be the issue, as I have installed codec packages. The most recent direct x files available for xp are installed. All windows updates are installed.

I am using 3 Gig of memory (more than enough for XP) and the harddrive has plenty of free space. I have tried disabling and enabling hardware acceleration for video.

So, what do I check next?

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

по рейтингу 0

Комментарии:

What does CPU utilization look like? Also, use an application like CPUID HWMonitor to see what the package temperature is.

от

CPU utilization is at 100% when playing videos on sites like youtube, but only if I try to move the cursor around the screen. Otherwise the system idle process consumes around 60% of cpu. CPU temp looks good. Stutters are minimal but noticeable once it gets going, but trying to do anything else causes immediate skips. AMD Sempron Si-42 2.10Ghz, 3GB ram.

от

Hi, Have you checked your network adapter? You say that it plays alright when "offline" but not when online. Also have you tried experimenting with the size of the Virtual Memory paging file? Here is a link

https://helpx.adobe.com/x-productkb/glob...

от

Yeah, I have tweaked the paging file, virtual memory, all the advanced settings. I even went into the display adapter and unchecked all enhancements and visualizations. It is interesting that you mention the network adapter, because that is what I have narrowed it down to. Unfortunately, it doesn't allow me to adjust many setting at all. A lot of times you can adjust a thousand things, but not with this one. The problem seems to be that the network adapter is somehow built into the system (probably not saying that correctly). But I fully agree that I believe the problem lies with the adapter. I mean I know the sempron is slow, but come on. The processor does a fine job for me - no gaming, etc. The driver I am using is not the proprietary driver (there isn't one for XP), but it works (but apparently with issues streaming). Whether or not we can iron that wrinkle out remains to be seen. Not life or death, but as a mathematician, I like to play around with this issues. Continued in next reply.

от

So the toshiba satellite L305D-S5974 has a Realtek RTL8187B wireless 802.11b/g 54Mbps USB 2.0 network adapter (or at least this is the driver installed): driver version 5.1163.331.2010 with a microsoft hardware compatibility digital signer. The device instance Id is USB\VID_0BDA&PID_8198\00E04C000001 and the Matching device ID is usb\vid_0bda&pid_8198&rev_0200

This makes me think, possibly, 2 things: 1, perhaps its an RTL8198 and 2, it is somehow worked into the video component (if that's what vid refers to). It is known that one can go to http://www.toshiba.eu/support/drivers/la... and enter L350D (mine is 305D) and use short part PSLE8E then XP (using service pack 3) but only the lan driver is offered - again implying that the wireless network card must be embedded somehow into the video component. Be that as it may, I previously installed windows 7 with the real actual drivers for this laptop (from toshiba america) and had the same issue. Perhaps I can get some sort of wireless usb stick?

от

Показать 2 больше комментариев

Добавить комментарий

Android Fix Kits

A new screen or battery is one kit away.

Купить сейчас

Android Fix Kits

A new screen or battery is one kit away.

Купить сейчас

1 Ответ

your CPU is the problem. the outdated cpu is having a hard time with modern day requirements. most likely a single core.

Был ли этот ответ полезен?

по рейтингу 0

Комментарии:

That's a convenient answer, but there is no reason why a single core 2.1 ghz processor with 2.75Gb of ram cannot handle a streaming music file (with no video mind you) without stuttering. I would say that it's simply not having the bonafide driver that's the issue, but that's clearly not the case since win7 with the real driver has the same issue. Although this particular laptop is manufactured with the economy sempron, I find it hard to believe (and I don't) that a computer manufactured post 2007 well into the heyday of modern internet could not handle a stream of music. But we can agree to disagree on that. I think an external wifi adapter should do the trick - I will keep you posted! P.S. It runs Mathematica beautifully and that requires 100% cpu consumption for factorizations of extremely large integers, so the cpu runs like a champ - I'm not a gamer, nor am I trying to watch netflix.

от

Добавить комментарий
Просмотр статистики:

За 24 часа: 0

За 7 дней: 0

За 30 дней: 0

За всё время: 109