iPad Mini 3 Home Button Loose after Digitizer Replacement

I have replaced my own iPad Mini 3 Digitizer and am having a little trouble.

I lost the small black Home Button Gasket adhesive Ring that seats between the Home button and Digitizer. It's pretty much a spacer. I tried to make one out of a notecard (failed), and then card stock paper with neither working to my liking. It always left too much wiggle room and the button was loose and moving around, but it definitely helped!

I also noticed the home button only "clicks" when the top half of the button is pressed. If I were to say "get a bad hold on the iPad" and only click the bottom half of the home button while using it, it would either not click, or barely click enough to register with the device. I have tried re-shaping the bracket a few times slightly hoping to create less or more wiggle room when needed, and each time I do the problem seemed to get worse to where the bracket doesn't even really seem to hold the button in place unless positioned perfectly and held in with adhesive.

I want to replace the home button O-ring Gasket but the only problem is most seem to be overseas or located states away. Aside from buying one which seems to be my obvious solution, would getting a new home button bracket, and the small gasket fix my problem of having a loose home button for those of you with more experience than I?

Additionally, would it be easier to purchase a fully assembled display assembly from somewhere and just replace their included home button with my original cable (to preserve TouchID)? I just hope they include that O-Ring gasket I need. Only reason this is more convenient is because I have opened this iPad so many times the adhesive on this new screen has dried up and each time I re-install it, it doesn't want to always stay put. Corners slowly start to lift and such. Dirt also gets under the screen and it's very hard to clean every time if I get fingerprints.

Image of parts I'm talking about are below! (The Part I need is on the left) http://www.fixmyapple.com.au/image/cache...




Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 0
Добавить комментарий