Перейти к основному содержанию

Released alongside the AirPort Extreme base station, this hard drive equipped variant offers 802.11ac speed on a time capsule NAS.

52вопросов Показать все

Replaced PSU twice still doesn't power on


AirPort Extreme Time Capsule A1470-2TB stopped functioning while it was on, all of a sudden, and without any warning.

No light, no noise of HDD spinning, or fan running.

I replaced the PSU (power supply), twice. None of the times Time Capsule worked again. Second PSU was fully tested according to vendor.

Could it be the logic board?

I don't seem to be able to track any logic board to buy for this product…

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 0
Добавить комментарий

4 Ответов

Наиболее полезный ответ

Use a multimeter and test the output of those power supplies.

Был ли этот ответ полезен?

Оценка 2
Добавить комментарий

Are you measuring with the board in the TC or just on the bench? I would expect the fan to spin with power on even if the board still failed to boot. Measure the power circuit on the board so you can see if it is shorted.. and not allowing the supply to start up.

One of the best tools around is an appliance wattmeter.. which you plug into the wall and plug the appliance into it to see how much power it uses.. they show a lot of details.. and if the supply draws next to nothing it is being shorted and not turning on.

Main boards for these will be a substantial portion of the cost so you won't find them as a part.

Был ли этот ответ полезен?

Оценка 1


Not sure which board is which in your first paragraph. If you mean checking the power circuit on the motherboard while PSU is connected to it, I didn't do that. I would not even know how.

How do you do that?

Unfortunately this is become academics anyway 'cos during one of the many detaching the connector from motherboard to HDD broke so the whole thing is gone now.

Thanks for the tips on the motherboard. I suspected it wouldn't be to be found.



I had the same issue, replaced the PSU and the fan turned on but nothing else. What else should I check as the logic board is not to be found anywhere.


Добавить комментарий

Done. Both work. 12, 2 & 12,3 volts

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

I had this issue with a recent job, replaced the power supply, but the connector to the logic board was not connected all the way in. So i got it all put back together and then had to take it apart again to reconnect that plug. Then it worked fine but I still have an issue with the screen. The user has it on full brightness all the time which is not normal, I think that may have caused an issue with the power supply, and the left side is darker now and I have seen all kinds of fixes for that, however I think the backlight is just bad. Good Luck.

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

Добавьте свой ответ

ittyo1 будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 0

За последние 30 дней: 0

За всё время: 211