Перейти к основному содержанию

Model A1286. Released February 2011 / 2.0, 2.2, or 2.3 GHz Quad-core Intel Core i7 Processor

579 Questions Показать все

Sparking MagSafe port no longer works

So a while back I noticed my MagSafe plug would spark when being connected or disconnected from the MacBook. Sometimes the spark would immediately switch the MacBook off and I'd sometimes lose what I was working on but most of the time it was just a worrisome spark. I cleaned up the connectors but it had no effect on the sparks or immediate shut downs. I went through forums and deduced that it was probably the MagSafe board acting up. Being frugal and confident in my repair skills I bought a board online, along with a new charger, and set to work.

Everything went fine but the sparks returned.

As before I tried unplugging the charger from the mains (3pin and other) before disconnecting the MagSafe and switching off the MacBook etc but that didn't stop accidental disconnections and the issues I was previously having continued.

A couple of weeks ago and my MacBook stopped charging again. With the last few percent of battery I powered down the computer I bought a new board from ifixit and successfully installed it and got the battery to a full charge.

I made the mistake of disconnecting the MagSafe to charge my wife's MacBook. I saw a spark and my MacBook wouldn't charge up again.

With the last few percent I powered down the otherwise working computer to look for a solution.

So now I have a working computer that won't charge. I don't know if the board has failed again so I guess I'm looking for help to solve this once and for all.

Any ideas?

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

по рейтингу 0
Добавить комментарий

1 Ответ

Наиболее полезный ответ

Don't lose hope yet. You still have a chance to save your MacBook before replacing the mainboard. My MacBook Air encountered similar situation: A faulty charger made my air no longer recognise the battery. It just says "no battery connected". The fan was always roaring despite nothing is running. The reason is that the charger made the SMC (system management controller) works improperly. Fortunately, the SMC can be manually reset. This guide from Apple tells you how to do so. If still no luck, then there may be a hardware failure

Был ли этот ответ полезен?

по рейтингу 1
Добавить комментарий

Добавьте свой ответ

Simon Webster будет вечно благодарен.
Просмотр статистики:

За 24 часа: 2

За 7 дней: 13

За 30 дней: 69

За всё время: 1,162