Перейти к основному содержанию

Third generation of iPad with Wi-Fi, released on March 16, 2012. Model Number A1416. Repair requires heating and careful prying.

154вопросов Показать все

Home button not working even after charging dock replaced, but charges

I have an iPad 3 WiFi only that came to me originally with a no charge problem. Upon visibly inspecting the charging port, I could see some of the pins were damaged so I ordered some replacement charging dock connector flex cables and thought it was going to be an easy fix. I was wrong.

I took the digitizer and LCD off and removed the original charging dock connector and installed the replacement charging dock connector. I tested to ensure it was charging, and it was. Fixed that problem. But when I loosely assembled everything to test the home button, it doesn't work. So I ensure that the gold contacts on the bottom of the home button bracket are lined up perfectly with the gold pins on the charging dock connector and they are. Still no difference. Home button does nothing when pressed, although it does charge.

So next, I replaced the home button bracket altogether with another I had. No difference.

Next, I swap out the replacement charging dock connector with another new one (I bought 3). No difference.

So next, under magnification, I inspect the pins on the logic board to see if any are damaged. Looks fine to me. I clean them up anyway with some 91% alcohol and try again. No difference.

Beginning to get frustrated, I DFU Mode reset the iPad and tried again. No difference.

What is going on here? All of the charging dock connectors I have tried do charge the iPad, but none of them allow the home button to work. I have swapped the home button bracket that has the physical click-button and gold contacts with another and it didn't fix the problem. The connector on the logic board doesn't appear to be damaged and I ensured it was clean. I DFU Mode reset the iPad. Nothing has worked and I am at a loss.

Where do I go from here? Thank you for any help.

Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка 0
Добавить комментарий

1 ответ

Выбранное решение

Alright, so after all of that troubleshooting, the answer was right in front of my face all along. I tried the third and final charging port connector only this time, I peeled off the sticker off the bottom of the replacement cable that adheres it to the aluminum frame of the iPad. There is what looks like a conductive area there that, once the tape is removed, makes contact with the aluminum frame. This one both charges and allows the home button to work. I'm assuming that the other cables would likely work as well, if I removed that tape and stuck it down to the frame, but to be honest, I'd rather not remove this one to test those and only cause this one to stop working for some mysterious reason, haha.

tl/dr: Peel the tape off of any replacement components first so if something needs to make contact, it can, and get more rest. :)

Thanks anyway.

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

Добавьте свой ответ

TechWizard будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 0

За последние 30 дней: 0

За всё время: 60