Перейти к основному содержанию

Mid 2012 model, A1278 / 2.5 GHz i5 or 2.9 GHz i7 processor.

1575вопросов Показать все

Laptop won't turn on for half an hour if turned off

I still have not managed to figure out exactly how the computer is behaving but it seems that whenever I turn it on (being it connected to the power supply or the internal battery) it will remain on without any problem until it is turned off.

Afterwards, it will require around 30 minutes completely off (with the battery connected to the motherboard, tho) to turn back on. During this time window, the following symptoms can be observed if the power button is pressed:

- The screen remains black

- No chime

- The fan starts to spin and immediately stops

- The sleeping light is turned on and immediately turned off

- If the power supply is connected, this will keep happening periodically (as if I keep pressing the power button). I still wasn't able to notice if this also happens when connected to battery-only.

I have already tested it with all possible combinations of ram chips in both slots, no hard drive, no peripherals at all, no DVD unit and SMC reset all with no success.

I have tried to turn it on without the battery connected to the motherboard but it doesn't seem to work at all, even after 30 minutes (plus the battery meter LEDs blink 5 times if I press the button to their side, but that's to be expected as there is no battery, right?).

What should I do? Any troubleshooting hints (even if it involves measuring voltages across the board)?

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 0
Добавить комментарий

1 ответ

Наиболее полезный ответ

Was this laptop behaving correctly when it was in your possession, or was it like this when you got it? If it worked at one point, was there a particular event after which the behavior started?

I would remove the battery entirely -- when troubleshooting, it's necessary to eliminate extraneous components, and since it works on battery power, we know it's not the battery.

My gut tells me it's a board issue, but as someone who doesn't repair boards, here's what I would do: Verify you get the same behavior with another charger. If this was a 15" machine, I'd verify you have an 85W charger (15" won't power on with 60W), but this is a 13" machine, so that shouldn't be the problem.

Once the charger is ruled out, I'd take out the board, eliminate any dust and corrosion you find, and then I would disconnect the DC-in, let the DC-in and board sit separately and disconnected from power for a few hours, and then put the machine back together. Sometimes a DC-in will acquire what I think of as a "bad charge", and disconnecting it and letting it sit allows it to dissipate.

Also, make sure the DC-in is aligned correctly. I do this by connecting it to power while its screws are out, and putting the screws in at that point so that you can verify the connector is straight as you tighten them.

Also, check for metal fragments/staples in the DC-in. I'd actually probably do that before any of this, now that I'm thinking about it....

Был ли этот ответ полезен?

Оценка 2

3 Комментариев:

Thank you for your answer!

Actually, I bought this machine brand new back in 2012. It worked perfectly until August 2015, which was when I moved to another country for a year and no one touched the computer until August 2016 when I came back. At this point, the described behavior was present.

I have actually tried to fully remove the battery and power it on only from the 60 W charger. That didn't seem to work. However, when it's on (which it is right now), it's possible to leave it connected to the charger. The magsafe plug shows a green LED and the battery icon in macOS says 'Power Supply: Power Adapter' (I don't know if that's the exact phrase because I translated from PT-BR but you get the point). That's not a false positive because I have had the machine on for the last ~10 hours and it's fine, which asserts that the power is actually coming from the charger.

What is the 'DC-in'? Do you have any sources where I can read more about it?


The DC-in is the small board inside the socket that the AC adapter connector (Magsafe) plugs into. Here's a guide. The more you describe the problem the more I think it's likely a board issue, but I'd still try what I mentioned just to be sure.

MacBook Pro 13" Unibody Mid 2012 MagSafe DC-In Board Replacement


As I don't have another charger available, I went directly to the process of letting the DC-in sit for a while, sepparated from the logic board. That didn't work as well.

Having the machine already open I took the time to clean it (it was really dusty) and inspect the components. Nothing seemed broken or burned. Only a silverish component that is quite blocky and sits close to the battery socket is rusty (what component is that?).

Also, yesterday I turned the machine off and had a hard time powering it on today. Being it connected to battery only or battery + charger it took definitely longer than half an hour to turn on.

It's really weird that sometimes the machine turns on and sometimes it doesn't... I am really curious to figure out what's the problem. Any other ideas?


Добавить комментарий

Добавьте свой ответ

Thiago Lobo будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 0

За последние 30 дней: 0

За всё время: 139