Перейти к основному содержанию

Afterglow glows, but doesn't work

Hello, I have bought an Afterglow Wired Xbox360 Controller about a month ago and plugged it to my PC with Windows 10 64-bit. It was working perfectly, glowing and rumbling, I was playing Dark Souls. Then I went with my family for about 2 weeks, and came home 2 days ago. I tried with The Witcher 3, to see how would it work with Afterglow, and worked without problems.

Today's morning I plugged my Afterglow, and it's glowing green by all LEDs, but Guide Button doesn't, and whole controller isn't working, neither with Souls nor Witcher. Windows doesn't beep when I plug or unplug it, doesn't see it at joy.cpl, Device and Printers or Device Manager, controller just glows green so he must be powered-up. I tried with USB in front and back of PC, still only glowing. Same problem with my friend's PC and Xbox 360, just glowing, not working. Could you help me?

Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка 2
Добавить комментарий

2 Ответов

Выбранное решение

I know I’m really late but I’ve been using afterglows for years and never have had problems with them until 2019 and 2020 now all of a sudden they won’t turn on I have probably bought around 8 in the last 2 years and none of them last longer than 2 months

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

Problem solved!

I opened the Afterglow, clean it up from dust and plugged, again just glowing.. While packing motherboard into xbox case, I thorn off the RB-sibe vibration motor by accident. I wanted to see if anything happend, plugged it to PC and it start working! Maybe glowing Afterglow means "problem with motors" or something like that.

Был ли этот ответ полезен?

Оценка 0

1 Комментарий:

Should add this comment 2 years ago: after a while, Afterglow stopped working again, so I ripped 2nd motor. It worked for a while, although without the vibration, and broke again, now there are no more motors to get rid of so its unrepairable for me. It does not interact with system, Windows does not pop when it is connected nor recognize in Device Manager, although the controller still glows with its green, nice light so can use it as a stylish xbox-controller shaped lamp,

I'd assume there was some circuit issue but I'm not into electronics and do not have a soldering iron and other tools to play around with it.


Добавить комментарий

Добавьте свой ответ

Stanislaw будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 1

За последние 7 дней: 7

За последние 30 дней: 45

За всё время: 6,345