Перейти к основному содержанию

Released June 2012, Model A1278. Intel processor with Turbo Boost, Up to 512 MB DDR5 Video RAM

1228 Questions Показать все

Install macOS High Sierra on RAID 0 SSD

Hi!

I have a MacBook Pro with a RAID 0 SSD setup so I can have a fast IO, worked like a charm for years...

Now I would like to upgrade to High Sierra and the installer informs me that: "You may not install to this volume because it is part of a AppleRAID.".

Is there any way to get around this?

If I do a clean install can I make a bootable APFS RAID?

Отвечено! View the answer У меня та же проблема

Это хороший вопрос?

по рейтингу 10

Комментарии:

Short answer - DON'T DO IT!

We will need to wait a bit until Apple releases an update for High Sierra with RAID support for APFS. Stick with Sierra for now!

от

When will I know when this happens?

от

you can install it on a USB Drive and the start from it, then create the RAID with the RAID assistent in the disk utility app, the n clone the USB with SuperDuper App to the RAID. now boot from the RAID with holding ALT at startup and set the startup disk to the RAID. but be aware all data on the drices will be erased when creating the RAID.

you can also clone your current OS on the RAID to a USB drive and update the USB to High Sierra an then clone it back with SuperDuper

Greetings Thomas

от

Great workaround and this will work. That said, I am not 100% confident in it upgrading with any future releases. I think I will wait till the 10.13.3 release and hope it addresses this issue as well as the root security exploit.

от

I think I'll let Apple finish High Sierra... This looks like one of those Microsoft Operating Systems (Win ME, Win Vista, Win 8)... I think for the first time in my life I'll skip a Mac OS version.

от

Показать 1 больше комментариев

Добавить комментарий

Комплект инструментов для замены батареи Macbook

Доступно с $69.99

Buy Now

Комплект инструментов для замены батареи Macbook

Доступно с $69.99

Buy Now

4 Ответов

Выбранное решение

Apple's APFS is still a work in process! Fusion Drives & RAID are still not supported yet.

In fact if you have a SATA SSD you're better off staying with GUID & Mac OS Extended (Journaled) for now as APFS has issues with queuing across a SATA interface (not an issue with PCIe SSD's).

You encounter time-points when you are saving a snippet, URL link or a file and the system will pause the action, yet the process you are running won't have any problems. I've see it take almost 30 sec for the file to show up on the desktop! Yet, if you do the same thing running the same actions on a PCIe SSD it won't stall-out.

Был ли этот ответ полезен?

по рейтингу 4

Комментарии:

I think I’ll wait some more time to upgrade...

от

Today I tried all the options to create a APFS RAID with no luck...

I made a backup of my data,

Erased my RAID with diskutil in Terminal,

Created a new RAID in RAID Assistant, the only Format option was Mac OS Extended no APFS option here,

Erased the new RAID volume in Disk Utility and created a APFS volume,

Next I tried to install Mac OS High Sierra, the installer allowed to chose the new APFS RAID volume and the installation starts normally but in the end (aprox 8 min) the installer gives an error: "Could not create preboot volume for APFS install"...

Tried using diskutil instead of Disk Utility and a new updated High Sierra download but the results ware always the same...

I ended up doing a rollback to my Mac OS Sierra backup... Frustrating!

от

I'm having the same issue.

I found this: https://www.forbes.com/sites/anthonykarc...

BUT, I'm not happy with the time, effort, and annoyance factor. I'm sticking with Sierra for now.

от

Добавить комментарий

The issue is APFS specific. So your options are:

1. Clean Install: Install to a standalone drive (separate from your SSDs), then use Disk Util to create or format your two SSDs RAID 0 and make sure it is formatted Journaled HFS+. Then clone the single drive to the RAID 0 volume and it will work.

I had tried this method using APFS on the RAID and it fails to boot. So the issue is APFS *can't* boot from RAID.

2. You can try upgrading to High Sierra, but without converting the file system to APFS. (I have not tried this myself).

Download High Sierra, but do not install it, then from the command line run:

/Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/startosinstall --converttoapfs NO --volume /DestinationDriveName

Был ли этот ответ полезен?

по рейтингу 1

Комментарии:

Option 2 does not work

от

Добавить комментарий

Use SuperDuper! to clone a disk with High Sierra to the RAID volume.

You cannot install High Sierra directly to a RAID volume. However, if you use SuperDuper! (which is free for this, btw) you can simply copy/clone the drive with the working High Sierra over to your RAID volume.

Some important points:

  • When you create your RAID volume, make sure it is in Mac OS Extended and not APFS.
  • You can actually be booted up in the High Sierra install that you’re intending to copy _from_ when you do this.

I’ve done this and it works great. Mojave might allow you to install directly to a RAID volume but I couldn’t do that because I was waiting for Nvidia to release their macOS video drivers with support for Mojave.

Был ли этот ответ полезен?

по рейтингу 0

Комментарии:

Hey Joshua. I did this and it works amazingly! But I have now run into the issue where I can't install an security updates. Do you have any advice to get these updates installed?

Thanks Chris

от

Hello,

I have the same issue. You can’t update MacOS when you did a copy of the OS via super duper or another one :-/

от

Sorry this doesn't really work

от

Добавить комментарий

Hi,

Just to tell you that the clean installation and update on a 21.5” iMac Mid 2010 (11.2 ) with x2 SSD Kingston SSD’s in RAID 0 16 GB RAM and has worked perfectly with the MacOS High Sierra Patcher Tool for Unsupported Macs, using HFS+ (not APFS)

We have tried it as a resource since High Sierra does not allow to install APFS on RAID volumes. Just Use: http://dosdude1.com/highsierra/

Block Image

Block Image

Excellent day!

Был ли этот ответ полезен?

по рейтингу 0
Добавить комментарий

Добавьте свой ответ

Caboz будет вечно благодарен.
Просмотр статистики:

За 24 часа: 6

За 7 дней: 80

За 30 дней: 377

За всё время: 18,250