Перейти к основному содержанию

The DC56 is a cordless handheld vacuum designed and created by Dyson. This page includes repair and troubleshooting guides for many issues that could happen to a DC56.

4вопросов Показать все

motor starts and stops when trigger is pressed

The motor on my DC56 starts and stops when the trigger is pressed. It used to run continuously if you didn’t use the boost button but now it does it all the time. There is no burning smells and the motor sounds OK.

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 3
1 Комментарий

Dyson stops and starts when you pull trigger

из

Добавить комментарий

Ответов (8)

Наиболее полезный ответ

I had previously cleaned the little purple filter which fixed the problem, but this time it wasn't working. I noticed that it worked fine without the bottom rotating attachment. I had to clean out hair on the wheel and also hair in the lip under the brush. When it starts and stops you just need to find out what to clean.

Был ли этот ответ полезен?

Оценка 3

2 Комментариев:

Yep, thank you. The roller head has to be taken out and cleaned, as well as the lip where the other lock symbol is. So just unlock both bits which have the lock symbols on them, take those bits off, and clean them. With the second bit, it’s not the narrow panel that you’ve just taken off, but it’s the pins still inside the head where the hair collects around. That one was harder to clean. I tried to saw at the hair with a knife, then pull it out with tweezers. It was still a pain in the butt!

из

I put the roller head in the sink and gave it a good clean out with a knife and hot water, then soaked in sugar soap and poured boiling water through it to really get all the dust build up out. Good as new now. BTW I thought the battery was going cos it was stop starting all the time :(

из

Добавить комментарий

Hi @audiq3 ,

Here is a link from the Dyson DC56 troubleshooting guide that describes what to check when you experience the problem that you are having.

Был ли этот ответ полезен?

Оценка 1
Добавить комментарий

I had the similar problem and fixed it through removing the nozzle at the front and cleaning it out. There were leaves and dirt stuck in there, and once cleared it worked perfectly once again. Make sure there’s not dirt or debris stuck elsewhere in the canister.

Another potential fix is to remove the air filter between the handle and the canister, shake it out (or wash, wring, and air dry it completely), and then flip it top to bottom so the tab at the opposite end is facing down (the side tab and “faucet” graphics will still face out as before). This didn’t solve my problem but might fix yours.

A third possible fix is to replace the battery. However this is a costly replacement, and my battery has lasted many years without any problems, so make sure you follow other troubleshooting tips first.

Update (11/21/2018)

Another helpful resource is this video guide to disassembly and cleaning of the DC56:

https://www.youtube.com/watch?v=KFj2eefV...

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

https://youtu.be/ZXioUi_-NPw

see this YouTube video. make sure u remove the whole net and clear all the dirt inside

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

I had this problem and had tried everything taking it apart. However eventually I noticed a little flap just inside the head of the hoover when you take off the stick and look in the hole. This little flap keeps getting stuck. Cleaned this out and now it’s perfect. Moisture just builds dirt on it and it keeps sticking.

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

I thought I had cleaned EVERYTHING and it was still pulsing. As I was about to give up and think it was just broken, I pulled out the long filter (the small cone-shaped one) and it looked clean on the outside, so I didn’t think that was the problem. I tapped it against my garbage and realized a ton of dust was trapped inside. Banged it on the trash can several times and VIOLA it’s working again!

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

I noticed that my switch worked fine when I removed the roller head piece so I knew the problem was somewhere around the rollerbrush. There was a buildup of trash around the top of the brush so I removed all of it with super long tweezers. Voila! Now it works fine again. At least next time I will know where to find the problem. Plus got rid of all the yucky lint etc.

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

I am still troubleshooting. I tried cleaning and testing after each step but noticed mine runs continuously when holding the button but ONLY when the canister is detached.

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

Добавьте свой ответ

Stephen Westerby будет вечно благодарен.
Просмотр статистики:

За последние 24 час(ов): 1

За последние 7 дней: 7

За последние 30 дней: 62

За всё время: 101,745