Перейти к основному содержанию

Released June 2009 / 2.66, 2.8, or 3.06 GHz Core 2 Duo Processor

296вопросов Показать все

Won't Start after Battery was Allowed to Run Down

So, I'd been working with an after-market battery, by Anker, which was reviewed highly on Amazon.

Overtime if the computer was run until the battery died, the computer wouldn't turn on. I'd have to remove the battery, hold down the power button to discharge any additional power, put it back in, and sometimes that little white light would come, and sometimes it wouldn't.

Sometimes it would take leaving the laptop without a battery overnight. I was able to get it to work the last 4 times that happened, but now, despite purchasing an Apple OEM battery, the unit is completely unresponsive.

The battery will charge, the MagSafe adapter seems to work properly, but going from the battery to booting the computer itself, nothing.

No spills, drops, or other catastrophic events.

Any ideas?

My wife needs this unit since it's her only computer and doing certain work on a tablet or phone is extremely inefficient. Thanks!

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 2

I'm a little lost here. You replace the battery with a Anker unit from Amazon and then you bought another battery from somewhere? This battery is not working either.

Did you calibrate the battery?

If it is able to run off of the MagSafe download this app: CoconutBattery take a snapshot of the main window of the app while the MagSafe is plugged in and then hopefully the system runs after you disconnect the MagSafe take a second snapshot. If you can also take a snapshot of the battery info button info as well. Post the images here following this guide: Adding images to an existing question


Hi Dan. The computer won't boot, so I can't take a screenshot. No response on the press of the power button. No white light to indicate the unit is receiving power. I bought the Anker battery months ago because the OEM battery was old and couldn't hold a charge. Based upon some cursory research, it seemed as though the battery could be the cause (particularly since the computer had problems booting when the battery drained completely). I bought the new OEM battery to apply this hypothesis, but without success. Still no power to the laptop. The magsafe adapter will charge the battery, but the battery won't power the computer. Oh, and it won't boot with the magsafe attached and the battery removed either.


Добавить комментарий

2 Ответов

Наиболее полезный ответ

Sounds like you have a charging logic failure. Lets work this out from stem to stern. First lets make sure the MagSafe is the correct one and also in good shape. Review this Apple T/N Apple Portables: Troubleshooting MagSafe adapters Also inspect the contact pins and the mating surfaces on your system if dirty use a cotton swab (Q--Tip) slightly dampened with 85% isopropyl alcohol to wipe them down.

Now lets plug it in and tell me what the color of the MagSafe cords LED bright Green, Amber, of dim Green.

Был ли этот ответ полезен?

Оценка 1


Hi Dan. Sorry for the delay. Busy times. I really appreciate your response.

The MagSafe adapter has worked for a number of months without issue. The battery has charged properly, and the computer could run without a battery with the same adapter. Only very recently did I start to run into these issues. I don't know if the adapter is genuine. I didn't buy it directly from Apple, though it did state it was an OEM adapter. I did check out the page you linked, as well as searched up how to recognize counterfeit adapters. This one states that it's an 85W. Again, it worked perfectly fine for many months. The lights do function properly, with the dim green, amber, and bright green. Last time I really had to push down the battery onto the pins to get the light to turn amber and for the battery to charge. Regardless, the battery had 75% charge when I got it, and it still wouldn't turn on the computer, so my thought would be that the issue is internal, between battery/adapter and computer.


If you had to press on the battery that sounds like the battery is gone.


Добавить комментарий

Hi are you using the correct power adapter and not an aftermarket one, for the 15inch if your not using a 85w adapter the computer will not boot on a dead battery and will appear dead. I had a similar issue and it was my replacement power adapter was a rebranded 65w not an 85w.

Был ли этот ответ полезен?

Оценка 0

1 Comment:

As far as I'm aware it's OEM, though there's no way to be sure since I didn't buy it direct from Apple. It's branded as an 85W, and it's functioned perfectly normally for perhaps a year now. Is there a way for me to test the actual wattage via multimeter?


Добавить комментарий

Добавьте свой ответ

Andrew будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 0

За последние 30 дней: 10

За всё время: 3,064