Перейти к основному содержанию

Model A1419 / Late 2012 / 2.9 & 3.2 GHz Core i5 or 3.4 GHz Core i7 Processor, ID iMac13,2

328вопросов Показать все

What causes “snowy” display on iMac screen after replacement

Completed the power supply replacement repair on a late 2012 27” iMac and at same time upgraded to SSD. Got display and everything sealed up and when I turn on I do get the boot chime, but what normally would be the grey loading screen is a grey snowy static with diagonal lines. No problem with logic board prior to this repair. Any suggestions on what happened? Possible that display cable did not fully click in and attach properly? Or could I have damaged the display cable during the repair? Please help!

Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка 2
4 Комментариев

Why did you replace the power supply?

Did your system suffer a lightning strike or power surge? Do you have a surge suppressor or UPS for your system?

из

Replaced power supply because iMac kept intermittently shutting itself off over past year. After bringing it to apple and scouting online forums came across the failing power supply as a possible fix. Apple said logic board was in good shape.

(Apple STUMPED - iMac shuts off randomly, daily to multiple times/hour)

Figured if I was going to open up my iMac for power supply replacement, I might as well upgrade the HDD to a SSD and get more bang for my buck. Used all the tools from the kit and was extra cautious when handling everything. This new snowy static (looks like an old tv) on boot is a new issue right after replacement. Could it be the internal DisplayPort cable not clicked in fully or with a broken pin?

Really hoping it’s not a logic board problem, but again this snowy effect is totally new and started directly after the upgrades I made today.

I never got to or saw the startup disk selector screen, as I was trying to boot from usb to install the OS on the new drive, but all I see is the snowy static (for lack of a better term).

из

What do you get when you hook up an external monitor? Did you address the run away fan issue yet? https://eshop.macsales.com/item/OWC/DIDI...

из

I also have the static snowstorm issue. Is it fixed by replacing the power supply cable altogether? Been scouring the web.

из

Добавить комментарий

1 ответ

Выбранное решение

Problem solved by cutting back through adhesive and disconnecting/reconnecting display video cable.

Был ли этот ответ полезен?

Оценка 1

1 Комментарий:

I tried reseating the cable a couple times and still has the exact same "snow" as you... do you have any other suggestions or did you come across any other possible solutions in your search?

из

Добавить комментарий

Добавьте свой ответ

Greg Blair будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 6

За последние 30 дней: 16

За всё время: 4,184