Перейти к основному содержанию

Model A1419 / Late 2012 / 2.9 & 3.2 GHz Core i5 or 3.4 GHz Core i7 Processor, ID iMac13,2

330вопросов Показать все

iMac stuck during booting from any HD, recovery mode, safe mode, etc.

Hi guys and gals!

I'm having issues with my late 2012 iMac 27" (EMC 2456) with an 3,2 GHz i5 CPU and the GTX 680 2GB.

What doesnt work:

  • The iMac does not boot but gets stuck on the gray screen with the apple logo and the horizontal progress bar. The bar stucks at the same position every time.
  • It boots neither from the new SSD nor the old SSD, nor any USB device, nor the Recovery Partition, nor into Safe Mode, nor can I install Mac OS through the Internet.

What I tried so far:

  • Reseting PRAM/NVRAM (Command-Option-P-R)
  • Booting into Safe Mode (holding Shift) doesnt work
  • Diagnostic (holding D) works but even the detailed search didnt indicate a hardware fault
  • Removed the RAM, restarted and got the alert from the logic board

Kernel Panic Log:

panic(cpu 2 caller 0xffffff7f8f04ed7a): "bool IOAccelDisplayMachine2::display_mode_did_change(uint32_t): vendor driver returns false"@/BuildRoot/Library/Caches/com.apple.xbs/Sources/IOAcceleratorFamily_kexts/IOAcceleratorFamily-378.18.1/Kext2/IOAccelDisplayMachine.cpp:490

Backtrace (CPU 2), Frame : Return Address

Kernel Extensions in backtrace:


dependency: com.apple.iokit.IOPCIFamily(2.9)[1850E7DA-E707-3027-A3AA-637C80B57219]@0xffffff7f8e894000


dependency: com.apple.driver.AppleMobileFileIntegrity(1.0.5)[54CD88E5-9FD7-30FC-89A0-E4B2D0CE6F85]@0xffffff7f8f013000

dependency: com.apple.iokit.IOSurface(211.12)[E998B85B-3174-3C25-B82B-C0D8BD9720E5]@0xffffff7f8f028000

dependency: com.apple.iokit.IOPCIFamily(2.9)[1850E7DA-E707-3027-A3AA-637C80B57219]@0xffffff7f8e894000

dependency: com.apple.iokit.IOGraphicsFamily(519.15)[D5F2A20D-CAB0-33B2-91B9-E8755DFC34CB]@0xffffff7f8ec04000


dependency: com.apple.iokit.IOPCIFamily(2.9)[1850E7DA-E707-3027-A3AA-637C80B57219]@0xffffff7f8e894000

dependency: com.apple.iokit.IONDRVSupport(519.15)[B419F958-11B8-3F7D-A31B-A72166B6E234]@0xffffff7f8ec5a000

dependency: com.apple.iokit.IOGraphicsFamily(519.15)[D5F2A20D-CAB0-33B2-91B9-E8755DFC34CB]@0xffffff7f8ec04000

dependency: com.apple.AppleGraphicsDeviceControl(3.18.48)[89491182-0B41-3BC3-B16F-D5043425D66F]@0xffffff7f8ec6a000

BSD process name corresponding to current thread: WindowServer

Mac OS version:


Kernel version:

Darwin Kernel Version 17.5.0: Mon Mar 5 22:24:32 PST 2018; root:xnu-4570.51.1~1/RELEASE_X86_64

Kernel UUID: 1B55340B-0B14-3026-8A47-1E139DB63DA3

Kernel slide: 0x000000000de00000

Kernel text base: 0xffffff800e000000

__HIB text base: 0xffffff800df00000

System model name: iMac13,2 (Mac-FC02E91DDD3FA6A4)

What I did prior to the crash:

2 years ago I deleted the fusion drive respectively split it into SSD and standard HD (just mention it in case its relevant for someone)

Yesterday I cut open the iMac and replaced the standard HD with a SSD (Samsung EVO 860 1 TB)

To avoid the fan running to high, I put an Thermostat from OWC (OWCDIDIMacHDD12 Inline-Digital-Thermo-Sensor) between the board and the drive

Did not put in new adhesive stripes yet but fastened the display with duct tape because I first wanted to check whether everything works.

Installed High Sierra through internet on the new SSD.

Whilst performing the migration assistant the monitor turned black.

Reopened the Mac. Disconnected and reconnected the 2 display connectors to the board. The display worked again and I finished installation (this time without the migration assistant).

After about 5 hours of installing, downloading stuff etc. I got a kernel panic.

The iMac then booted neither from the new SSD nor the old SSD, or any USB device. Not even the Recovery Partition.

I opened the Mac and noticed a mellow smell like burned circuit but could not locate that smell. My wife could not smell it so I though I might be wrong.

Next day, I removed the OWC thermostat. The Mac booted again from both disks and seemed to work fine again for a while.

After about 2 hours however I got the kernel panic screen again. I opened the iMac again and I though I smelt something burned again.

Any suggestions on how to proceed would be highly appreciated!

Kind regards


(Edited: editorial changes and kernel panic log)

Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка 2
7 Комментариев

It would be helpful to see what you got for kernel panic errors. Try to see if the system will boot up under Target Disk Mode holding the T key when you restart the system. If you can get it into Target Disk Mode connect via USB or Thunderbolt cable between your system and a second Mac. The iMac's drive should show up as an external drive. If you can't get to it that way you'll need to take the drive out and connect it to the second Mac.

Did you take out the logic board? Or only disconnected the HDD drive cables when swapping out the HDD for the SSD.


Hi Dan, thanks a lot for your response.

The kernel panic stated "You need to restart your computer. Hold down the power button until it turns off." in several languages.

The iMac does go into Target Disk Mode. Though I did not try to access it that way, I assume that the SSD is not the issue, as the iMac does not boot from any of the internal nor external (via US) drives.

I did not take out the logic board but only replaced the HDD with the SSD.




Well, thats good news! So the logic board is OK. Still may have an issue with the drive interface and drive.

If you can connect the second Mac to retrieve the log file as it will have the details on what happened during the startup.

How did you choose which drive to boot up from? Review this useful Apple T/N: Mac startup key combinations. You needed to use the Option key to gain access to the alternate drive. See if that works.

You might want to give the onboard diagnostics a go to see if it pops an error code if it does write it down and post it here for us to see.


You talk about the Samsung EVO 960 SSD. Are you sure this what you used? As it's a M.2 blade SSD not a Samsung 860 EVO SATA drive which is what you need.


Sorry, my bad! Of course I meant the EVO 860. I had to order a Firewire Cable to read the kernel panic logfile and updated my initial error report (see above).


Показать 2 больше комментариев

Добавить комментарий

Ответов (4)

Выбранное решение

Well, the crash report is telling us the GPU logic has a failure! It looks like the VRAM 512 MB/1 TB of dedicated GDDR5 memory is failing. Sadly nothing you can do here other than replace the logic board or find someone with the needed skills & tools to do the micro-soldering to try to fix the logic board.

Был ли этот ответ полезен?

Оценка 1

1 Комментарий:

Thanks a lot! Though I was of course hoping for a different reason, a failed GPU is what I had been expecting diagnosis.


Добавить комментарий

Replace all the cooling fans . Mine did this a few times and right after I replaced the HDD.

I now have went thro a few HDD becouse the HDD was not apple certified.

To control the fan speeds . I tried fan control software but it sux.

Just replace the fans and add apple cert. HDD and it should be fine.

P.S. disconnect the cd drive and try a boot also.

Был ли этот ответ полезен?

Оценка 0

2 Комментариев:

I bet if you installed this: OWC In-line Digital Thermal Sensor for Hard Drive Upgrade for 27" iMacs 2012 and Later you wouldn't have burned out the fan's as often. OWC had a few other units in case you have a different series than the 2012 model


Thanks a lot for your input. However I am pretty sure the HDD is not the issue as I cant boot with or without the drive and also not from external devices (via USB) or start into recovery mode.


Добавить комментарий

Has it been possible to solve the problem?


Был ли этот ответ полезен?

Оценка 0

1 Комментарий:

I did not invest in another Board so I cant say for sure that a replacement would have fixed the issue. But I am pretty sure the GPU was causing the trouble.

I hope this answer is not to disappointing. Cheers


Добавить комментарий

i have the same issue, i replace the hdd to ssd and after 5 minutes that working fine i had a blut line on screnn and then restart and im in boot loop ever since… no recovery mode no safe mode nothing works…

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

Добавьте свой ответ

hassscrabbler будет вечно благодарен.
Просмотр статистики:

За последние 24 час(ов): 1

За последние 7 дней: 7

За последние 30 дней: 20

За всё время: 7,803