Перейти к основному содержанию

An Uninterruptible Power Supply (UPS) is an electrical device that provides backup power to critical equipment in the event of a power outage or other power-related issues.

Вопросов 48 Показать все

It won`t charge but It can only use Battery power.

I need help with my UPS. It won`t charge the battery that I replaced but It can use battery power. I replaced the battery that came with the ups (because its defective) and the replacement battery is charged. I replaced the battery with the same specifications (same amps and volts. no slight difference. EXACT). I used the replacement battery and it works fine. After Im done using it. I tried to charge it for 8 hours. Then I use it again. It won`t start and gives slightly-long beeps which means its low. Connectors are brand new and tested with other appliances. Fuses are tested with multimeter (Board fuse 2x 30 amps and fuses at the AC input female). I checked continuity of the wires and all of them are in good shape. Can anyone help me? You can tell me what to do with the board (I have knowledge about electrical and experience in soldering, etc). Do I need to change something like a capacitor or a mosfet in the board? I can send a picture of the board itself ASAP right when you asked for it.

Brand: Powercom Black Knight Pro

Model: BNT-650A / 650A

Board Model: BNT V3.0

Battery: CS3 GP 1272 F2 [12 volts 7.2Ah]

Battery is in good condition. Tested with another UPS.

Thanks in advance :)


Diagram (Source: ElektroTanya):

(1) SCHEM1.pdf

(2) SCHEM2.pdf

Images (Source: Mine):


Block Image


Block Image


Block Image


Block Image


Block Image


Block Image


Block Image


Block Image


Block Image


Block Image

Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка 2
4 Комментариев

Hi @ fbmt, it would be good if you can post more pictures,

How long is the UPS in operation?

If the UPS has been operating for some time, would suggest you also inspect the board for any "cold joint" solders


@salmonjapan I already added pictures. Kindly check. Thanks :D



That is helpful :)

Hopefully we are able to assist you to fix the issue.


I will say check where the AC passes to the board (input) and see if it will give you DC (output) from the battery connectors


Добавить комментарий

Ответов (3)

Выбранное решение


Can you measure the voltage across the battery terminals when the battery is in charging mode?

BE SAFETY AWARE when you do this. Watch out for the AC connections etc.

It should be in the region of 13.8 - 14.5V DC.

Here's how to add pictures on ifixit

Adding images to an existing question

Был ли этот ответ полезен?

Оценка 2

4 Комментариев:

Its always in operation (always plugged in and battery is used often. The electricity on where I live isn't stable). and What do you mean by cold joints? Since you didn't ask for what picture (either motherboard schematic diagram or the physical picture). I will upload both of them right away.


There were no voltage readings while in charging mode / mains connection. I'm assuming that the board needs to feel the battery first in order to charge the battery. The transformer (which I believe its working and 99% fine / good condition) is working. If its not. How can the 12 volt charged battery make a 220 volt output? Surely the transformer is working (I dont know how to test a transformer COMPLETELY)



The 12V battery supply is fed to an inverter which converts it to 220V AC,

Reading the brochure your model is a line interactive type so that the battery should be charging while the mains are available.

Here's a link that explains it better than I can.

Look at the images to the right and slightly below the Line Interactive paragraph to see how this type of UPS functions.

You can see that when AC power is available the battery should be charging. So the battery charger section of the UPS is either not getting the power to charge the battery, not being told to turn on to charge the battery or not supplying the power to charge the battery.

This is what I meant when I said check the voltage supply across the battery terminals, to see what charging voltage if any was present.

You should read the battery voltage (should be around 12V but if discharged is probably less) whereas if it is charging as I said it should be around the 14V mark. If more then 12V but less than 13.8V the battery won't charge properly.

Again be careful as there are LETHAL voltages present inside the UPS.

Cold solder joints are soldered connections that were not done properly and the connection becomes open circuit. Suggest that you check the transformer connections to the motherboard, especially the terminals associated with the output to the charger section of the UPS. Obviously do this with the power totally removed from the UPS. Also use a strong light and magnifying glass to check because sometimes a bad solder connection can look OK until you really look at it closely.


@jayeff I measured the battery's voltage and I got 11.9 volts. I plugged in the UPS to the mains ( I do wear electric gloves for protection ) and check the voltage while plugged. The battery terminal's voltage while plugged in is still 11.9 same with the battery itself. I let it charge for an hour (while waiting for a reply from you guys) and I tried to turn it on. Still have the slightly long beeps which means its low. I also checked the connections between the board and the transformer. Everything is secure and tight. I managed to unplugged them with a bit of a force for the images that I took. After putting them back again. I double checked if connections aren't lose and making proper contacts. Please take a look at the images that I uploaded. I can add more if necessary / needed.


Добавить комментарий

Hi fbmt11,

interesting video


Был ли этот ответ полезен?

Оценка 2

15 Комментариев:

How to test / check if my relays are working fine? I got several of these from dead electronics.


@salmonjapan It`s very challenging to desolder more than 2 pins. I need to make sure if the relays already on the board is working :o


Hi ,

To test the relays with the board unpowered, connect your spare old 12Vbattery directly across the relay coil terminals. There should be enough voltage in the battery to operate the relay. It should click operated every time you connect the power. Connect the +ve battery lead to the relay coil terminal which has the cathode end of a diode connected to it (stripe on diode) and the -ve battery lead to the terminal which has the anode end of the diode - this is for relays RY1A and RY2A if you connect them the other way the diode may shunt the relay preventing it from operating

If this doesn't work you can test the relays by using an Ohmmeter to measure the resistance of the coil winding. It may differ depending on which way you connect the test leads to the coil terminals as there is a diode in parallel with the winding for relays RY1A and RY2A. Test it both ways (reverse the leads) to be sure you're not just measuring the diode! If in doubt unsolder one leg of the parallel diode and then measure again

Disconnect the power from the board and then connect the meter directly across the coil terminals and you should get a resistance reading.

To test them electrically using the board's power, connect power to the board and use your voltmeter to see if there is +12V present on one of the relay coil's two connection terminals. Test between the relay coil terminal and Earth.

If the coil resistance measures OK (not open circuit (o/c) and the +12V is there you could connect an Earth lead from an earth connection on the board to the OTHER relay coil connection (NOT the +12V connection point on the relay) for THAT relay. The relay should operate and you should hear a "click" as it does.

BE CAREFUL - if you connect the earth lead to the wrong point you could damage something.


@jayeff Yo, This blew my mind. How do I know which one are you pointing? By the way this is my first time testing a relay (5 pins, The model of the relays are 812H-1C-C having 5 pins). Well the first part makes sense to me. I do hear clicking when 12v power is connected. I appreciate your effort helping me. It will be great if you could simplify it for me. I'm very sorry if I can't understand it well. Thanks for helping me and giving information. I hope other people could find this information helpful.


Hi @wolfpup02 ,

Here's the data sheet for the type of relay.

The bottom view wiring diagram on p53 (really only p,3) shows the coil tags (tags with vertical jagged line connecting them) and the 3 other tags belong to the changeover contacts of the relay i.e central lever arm moves up to BREAK contact with lower contact and to MAKE contact with upper contact when relay operates.

So perhaps your relay tags look like a row of 3 and another row of 2 above. and the coil tags would be the outside tags on the row of 3.

Hopefully this makes sense.


Показать 10 больше комментариев

Добавить комментарий

Measure the resistance of F1 you should get 0.1ohms. On your board it is used as a fuse.

You do have the right schematic, all you need to to is to test the voltages on the point shown on the schematic. That way you know where you have power and where you do not. A picture of the board alone and straight down on it will help us to see the designators on the board better.

Был ли этот ответ полезен?

Оценка 1

7 Комментариев:

Hi fbmt11, as advised by @oldturkey03, measure / check F1 on the resistance and also Fuse 1 and fuse 2 (car fuse) for connectivity.


F1 (which I believe its only one) gives 0.1 ohms

FUSE1: has continuity

FUSE2: has continuity

Both fuse are 30 amps


fbmt11 the value for F1 is correct it has 0.1Ohm resistance. Next check the voltages against your schematic. You do see the voltages listed on the schematic and see where you lose them.


@oldturkey03 Which PDF did you refer? 1 or 2?


Number 1 would work


Показать 2 больше комментариев

Добавить комментарий

Добавьте свой ответ

fbmt11 будет очень признателен(а).
Статистика просмотров:

За последние 24 час(ов): 3

За последние 7 дней: 6

За последние 30 дней: 49

За всё время: 9,853