Перейти к основному содержанию

The phone doesn't prompt for "Network unlock code"

Simply i am stuck!

A couple of services for unlocking locked devices rejected me because my device doesn't prompt for unlock code.

When i insert non supported sim card the device reboots and that's it, no prompt for entering unlock code, nor when i inserted another sim.

I tried with force USSD code to show me the unlock menu but that doesn't work either.

Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка 2
Добавить комментарий

3 Ответов

Выбранное решение

Can you confirm that the phone reads the sim card properly?

It sounds like the phone is rebooting on sim insert because the sim detection pin (basically a spring mechanism in the sim reader) gets triggered and tells the phone the sim tray / sim card has been inserted.

If it says no sim card detected on the lock screen or in the status bar (notification bar menu) the sim card is not being read due to either the sim reader being damaged or the phone having a no baseband or no IMEI issue.

To ensure the sim card is being detected go into phone settings > more > mobile networks

On that page it should display only the network settings for your service provider (the sim card you inserted) if it's blank then it's not reading the sim properly. Try doing a call as well, it will tell you to insert sim card if it has not detected one.

You can check imei (15-digit number) and baseband (version) under phone settings > about phone > phone status / phone info.

Был ли этот ответ полезен?

Оценка 3


In fact there is a baseband version the IMEI looks okay, but when i go to "SIM Status" everything is "Not available". When i try to call it says there is no mobile network available. And the phone doesn't even detect the inserted card in the notification bar.

First i was thinking that it was a software issue so i flashed a new firmware, but now it begins to clear up when you shed some light. I will open the phone and look at the reader, maybe replacing it will fix the problem. I will update the thread asap.


One of the pins of the old sim card slot was broken i replaced it and now it works, the phone prompts for unlock code!


No problem glad I could help.


Добавить комментарий

You can use code. You can add sim to mobile and then use code 7465625#. Now it ask for unlock code use your code.

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

I'm having the same issue with Motorola g stylus 5g 2021. No place to put code

Был ли этот ответ полезен?

Оценка 0

1 Comment:

Same problem too ,I have the unlock codes but my phone(Motorola g stylus 2021)no where to put the code


Добавить комментарий

Добавьте свой ответ

Angewolf будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 24

За последние 7 дней: 93

За последние 30 дней: 375

За всё время: 12,451