Перейти к основному содержанию

Model A1419 / EMC 2806 / Late 2014 or Mid 2015. 3.3 or 3.5 GHz Core i5 or 4.0 GHz Core i7 (ID iMac15,1); EMC 2834 late 2015 / 3.3 or 3.5 GHz Core i5 or 4.0 GHz Core i7 (iMac17,1) All with Retina 5K displays

578вопросов Показать все

iMac won't start up. No diagnostic LEDs. PSU tested fine (see . below)

By the way, the model I have is the "late 2015" that shipped with i5-6500 processor. This is the skylake processor family.

The iMac was working condition yesterday. I opened the iMac to replace the processor and replace the HDD. I chose the best processor compatible with this model: i7-6700K.

When I put everything back together and tried to power on, it won't come on. I do hear a small clicking sound when I plug the power plug in to the outlet (this is probably a spark when I insert the plug as its localized to the output, and not near the PSU). I do not see any diagnostic LEDs turn on even when plugged in.

1) Measure AC inlet cable, showing 120.8volts

2) Measure the PSU supply rails. There's 4 solder points, but only 2 are marked. GND and +12v. When checking these solder joints I can successfully measure +12volts between GND and the +12v rails. I also verified that the cable (12 pin?) also measures the correct voltage.

3) I checked the power button itself, and when I press it I can measure almost 0 resistance between the cable's two contact points (indicating that the power button is working fine.

4) I checked the PSU signal cable that connects to the logic board and I verified that each rail/wire is correctly connected and not shorted or damaged.

5) I checked RAM seating and tried different combination of slots and testing 1 at a time, and 2 at a time.

6) I checked voltage of the battery under the logic board (measures 3v).

7) I opened everything up and examined the CPU socket pins. There was some mis alignment I could see in the iPhone's magnifier feature and I corrected that. And reseated the CPU and still got the same behavior.

8) I put the old CPU back (i5-6500), same result.

Any help is appreciated! I am trying to isolate the issue, but can't seem to figure out how to find the problem part. Any steps about testing the PSU would be appreciated.

Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка 0
1 Комментарий

I've got a 2nd PSU on order, and will keep you updated. In the mean time any tests to determine logic board failure or PSU failure would help

из

Добавить комментарий

Ответов (4)

Выбранное решение

all these iMac ranges have diagnostics LEDs on the board. on this range they are on the lower left of the board.

If you are not getting the first LED coming on when plugging it in, then there is no trickle charge from the PSU. This either means the logic is shorted and damaged, or the PSU is dead.

If the LED is coming on, and the 2nd doesn't come on when the power button is pressed, check the power button to make sure you haven't squashed it between the speaker and PSU, as its really common to damage it in that way, then check the PSU or logic.

But if it was fully working beforehand, and you've fitted a non-standard CPU and proper antistatic precautions were taken during the rebuild, its likely the logic board at fault unfortunately.

it is difficult to say for sure without seeing the machine, but i hope this helps.

Block Image

Был ли этот ответ полезен?

Оценка 4

5 Комментариев:

I've added a photo above remarking the diagnostics LEDs on the logic board. That should help.

1st LED is the indication of a trickle charge.

2nd is an indication of power being received (machine turned on)

3rd indicates the GPU and computer are communicating

4th indicates the computer and LCD panel are communicating.

If you're not getting the 1st LED, its either AC related (mains cable, plug socket, AC filter issues, etc), PSU or logic board.

из

It was a faulty logic board. Since it was in working condition before I opened it, it was probably something I did. Unfortunately its impossible to tell what went wrong. I doubt it was the CPU - since that would not prevent the light to come on. It was probably some thing related to the PSU which fried the board. Or perhaps I handled it just the wrong way - just the wrong place. Just highlights the fragile nature of working with these things.

из

that is very unfortunate, but you are right, they are very sensitive devices. Sorry to hear that it turned out to be the logic though.

из

I am have the same computer that was working fine yesterday with no problems. Never been opened up. I woke to a completely dead computer. I tried unplugging replugging. Two different power cords and nothing. I opened it up and get no LEDS lit when plugged in. What are the odds it is the PSU? Worth trying that first? Thank you

из

Did you resolve this Todd - got same issue

из

Добавить комментарий

I am having a similar issue to this. This morning I dismantled a late 2015 iMac 3.2GHz that was yesterday working without issue. I did a routine heatsink service and replaced the thermal pads and paste. I also fitted a Crucial P3 NVME blade with a Sintech adaptor. Everything was cleaned with an electric air blower prior to reassembly.

Before attaching the display I always do a routine diagnostic check to see if LED 1 comes on. But I got no sign of life at all. This was all with the same power cable used with the machine yesterday and the same socket. I swapped the cable out for a known good one and used a different power socket - still no LEDs.

None of this makes any sense to me. I have worked on hundreds of iMacs, not done anything differently and in this instance the machine was working perfectly before. It just had a worn hard drive which was the initial reason for working on it.

Был ли этот ответ полезен?

Оценка 1

1 Комментарий:

These things are extremely sensitive. Most likely something probably shorted while you were working on it, and the logic board is probably has some defect now. Unless you are Louis Rossmann, or someone who has a tons of diagnostic equipment (like thermal cameras, or microscopes), I think it will be hopeless to try and fix. Who knows which capacitor or which resistor is now dead, making the whole thing not work.

I know this is not what you probably wanted to hear, but that is exactly what happened to me, years ago.

из

Добавить комментарий

Exactly the same here.

I also opened a working device for NvME (WD) update with a Sintech adapter. I also strictly used to be electrostatic discharged. I did not do a CPU replacement. After connecting all components back the iMac did not give any signs of life. All diagnostic LEDs were off. Used a known working PSU did also not changed the behavior. I also replaced Hardware and build up many Computers in my life but Apple seems to be extremely fragile…

Был ли этот ответ полезен?

Оценка 1
Добавить комментарий

If you removed the heatsink to renew the paste then you will have removed the CPU die as I did. There is only one right way of refitting the CPU as it has notches that match others in the socket, so they must match

But you also have to use the pins on the clamp that sits on the other side of the board to help locate the heatsink. Then once located it must be held in position until you can get two screws in to keep it there - not done tightly - just enough to prevent anything moving.

This was my problem. The heatsink moved slightly while I was trying to get the first two screws in. But I carried on not realising that the die had also moved.

Once I found out the Mac would not turn on, I dismantled it again to find I had slightly bent the CPU die.

Fortunately, an identical replacement with the correct socket code ultimately fixed it and the Mac now works faultlessly.

Был ли этот ответ полезен?

Оценка 1
Добавить комментарий

Добавьте свой ответ

Maharaja будет вечно благодарен.
Просмотр статистики:

За последние 24 час(ов): 1

За последние 7 дней: 8

За последние 30 дней: 27

За всё время: 1,468