Released December 2012, identified by model SPH-L300.This Android phone holds 4G LTE data, a memory card slot, 5-megapixel main camera, front camera and Samsung's S-Beam for fast file transfers.

5 Questions Показать все

Samsung Galaxy S5 G900F

Galaxy is not in the menu this refers too: Samsung Galaxy S5 G900F

When the phone is switched on, the start up logo sits there the phone does not boot up?

I cannot gain access to the phone, no matter what I connect the phone too, (i.e. Kies, Smart switch?

Отвечено! View the answer У меня та же проблема

Это хороший вопрос?

по рейтингу 0
Добавить комментарий

2 Ответов

Выбранное решение

This is usually caused by either one of the following:

* System software getting corrupted, can be caused by a system update, not enough space on phone or for no apparent reason.

  • Power management chip going faulty (This requires micro-soldering board level repair to fix)
  • eMMC chip (Flash memory / a.k.a hard drive) going faulty (This requires either getting the flash memory chip replaced or reprogrammed by a JTAG (flashing box, again like board-level repair).

If you are lucky sometimes this can be fixed by reflashing the System Software (Firmware) on the phone.

Here is a link on how to reflash firmware on Samsung devices:

http://updato.com/how-to/how-to-install-...

Был ли этот ответ полезен?

по рейтингу 2
Добавить комментарий

Thanks for your reply Ben.

I tried using Odin but it failed “error” no pit file. I next used smartbox got pit file tried to flash phone still no luck. It must as you said be an electronic fault. I need info from the phone but I can't access it.

I'll have to take it to a reputable phone service to be repaired if it can be!

Thanks once again for insight!

Был ли этот ответ полезен?

по рейтингу 0
Добавить комментарий

Добавьте свой ответ

John Banks будет вечно благодарен.
Просмотр статистики:

За 24 часа: 0

За 7 дней: 0

За 30 дней: 24

За всё время: 24