Перейти к основному содержанию

Released October 24, 2011 / 2.2, 2.4, or 2.5 GHz Quad-core Intel Core i7 Processor

365 Questions Показать все

Weird audio problems with MacBook

A while ago I thought I blew up the audio chip in my macbook as I put too much signal through it. After I did that, the macbook shut down and when I booted it back up, it had no audio. The speakers didnt work, 3.5mm jack didnt work and when I went into the audio settings, there was no devices shown.

Recently I installed windows with the same result with the audio.

But when I turned it on and went into windows, the youtube video I had up last night was playing through my speakers. But when I went to try an audio test, they quit again.

I checked the Microphone input for the built in mic and it shows full bars, telling me its always picking up sound, which it is not.

The speakers also make a very quiet popping sound, only hearable when right up next to them, It doesnt change when volume is changed.

The other day, there was a red light shining or blinking (I dont remember) from out of the audio jack when it was closed and charging. Not sure if its related at all but I thought I would mention it.

If anyone knows what the heck is going on, your help would be much appreciated.

If there is any more info you need to know or any questions, Please ask!

Thanks!

Update 9/2/18

@mayer Heres the results from coconut battery

Block Image

Block Image

Отвечено! View the answer У меня та же проблема

Это хороший вопрос?

по рейтингу 0

Комментарии:

Have you tried booting up on an external drive which has a fresh copy of macOS installed?

от

No. But how would that change anything?

от

The idea here is to remove OS level issues.

от

Ok I'll have to try that when I get home in a week. Anything I can try in the meantime?

от

@danj for some reason, when i booted it up today, it chimed which it has not done since I blew the chip. And when i went into windows, the sound worked for a little bit but stopped shortly after. I'm not sure what's going on. But it's very strange

от

Показать 9 больше комментариев

Добавить комментарий

2 Ответов

Выбранное решение

The red light from the audio port might mean the little switch inside is jammed and needs to be cleaned to get back in place. Some electric contacts spray cleaner with a toothpick might help in getting it back into place. I’d give a try at that first.

Был ли этот ответ полезен?

по рейтингу 3

Комментарии:

Thanks. I'll try that. But it only did that that one time, but I haven't seen it since

от

Run an audio jack in and out of it a few times.

от

Ok. @mayer but I'm not sure that's the problem. As audio works for a short time (less than a minute) and then doesnt work again unless I restart it. I'm probably wrong but it would probably not work at all, or work intermittently if that was the case

от

If you are getting a red light in the audio out port, the computer thinks it is outputting to an external speaker.

от

@mayer I tried that but no changes also, the light was only that one time, I haven't seen it since

от

Добавить комментарий

Go to “about this Mac > System report > Audio

see what is listed as the “Default System Output Device”

UPDATE

Sounds like your sound flower driver may be the issue.

Go under the Apple icon to System Preferences >

Sound >

Select the Internal Speakers

Test with the Output Volume bar.

UPDATE 9/1/18

how to remove soundflower from a mac

To uninstall it, please follow the steps below:

  1. Please go to Finder-> /System/Library/Extensions.
  2. Find Soundflower.kext.
  3. Remove it, then reboot your Mac.
  4. Reboot [seriously!] - This part is important! To ensure that the driver is unloaded correctly, you do need to reboot. Failing to do this part can result in update / installation / general weirdness (tm).
  5. Soundflower plug-in will be fully removed from your Mac.



Был ли этот ответ полезен?

по рейтингу 1

Комментарии:

@mayer it says that soundflower 2ch and 64ch is default. I installed it a while ago for something but haven't had any problems since that day. It also doesnt explain why it works for a short time, and why it didnt even show any audio devices for the longest time besides the soundflower ones.

от

@mayer already tried. That's what's selected. When it works, then it stops, even with that selected

от

Get rid of sound flower, then re-set it again.

от

How about trying setting up a new user account ?

от

@mayer I tried but it didnt go away. Its not in my launchpad but it didnt go away.

от

Показать 14 больше комментариев

Добавить комментарий

Добавьте свой ответ

Cameron будет вечно благодарен.
Просмотр статистики:

За 24 часа: 2

За 7 дней: 5

За 30 дней: 26

За всё время: 414