Перейти к основному содержанию

Четвертое поколение iPhone. Ремонт прост, но дисплей должен быть заменен в сборе с сенсорным стеклом. Версия GSM; 8, 16 или 32 ГБ памяти; модель A1332; в Черном или Белом цвете.

2354вопросов Показать все

Phone not starting after battery socket repair

Hi there!

I accidentally tore my iPhone 4’s battery socket from the motherboard.

I soldered a new one with solder paste. I have checked continuity between each pin and the corresponding test point, and it seems fine.

Yet when I plug the battery back, and the charger, nothing happens.

I have 2 clues of what might be wrong:

1) when I plug the charger, without the battery, and measure voltage on pin 4, I get only 1.15 V. Is that what is expected? It seems low to me, however I also get that same voltage on the test point, so it doesn’t seem to be due to a bad solder

2) I tried testing related capacitors, and I can’t make sense of capacitors connected to pins 2 and 3:

  • when I test continuity between pins 2 or 3 and ground, there isn’t any continuity
  • however when I try to measure resistance between them and ground, I get infinity, I don’t get an increasing value as I would get with a working capacitor
  • also, after trying to measure resistance, when I measure voltage on pins 2 or 3, I still get a steady 0, instead of a decreasing value

I don’t really know why these capacitors would be damaged, since they are under the EMI shield. I did try soldering several times and had difficulties, but it seems unlikely to me that they would have been damaged in the process

I also checked the capacitors connected to pin 4 with the same method: I have no short to ground, measuring resistance provides a steadily increasing value, and measuring voltage after provides a steadily decreasing value.

Any idea what might be wrong?

Thanks in advance for your help!

Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка 0
Добавить комментарий

2 Ответов

Выбранное решение

So my question is … what was the original repair for? What were you doing when you accidentally ripped the connector off? That may give you some clues as to why the phone isn’t starting.

I haven’t worked on a lot of iPhone 4’s but here are my thoughts…

  • There is no continuity between pins 2 and 3, they are separate circuits.
  • The capacitors are so small that you wont really see the charging effect. They are full charged by the time your meter can update the value.
  • The same applies on discharge,
  • Using diode mode gives you a different reference point, something that can be used in a comparative fashion which helps in troubleshooting.
  • There is a possibility that while you see continuity between the connector post and the test point, the actual trace to goes to the components underneath the shield are damaged. You would have to remove the shield to check continuity up to those components.
  • Finally, you say you struggled a bit. It is possible that applying too much heat caused issues with the main IC’s (CPU, NAND, PMIC etc). iPhone logic boards are very thin and heat travels very quickly. Too much heat and you could have shorts underneath the IC’s. If all else fails, start probing the PMIC output rails to see if any are shorted.

Был ли этот ответ полезен?

Оценка 3


Thanks a lot for your reply! I really appreciate your help.

To answer your questions and points:

- "what was the original repair for? " I just replaced the mute and volume up/down cable, nothing fancy. I just tore the battery socket when disconnecting the battery

- "The capacitors are so small that you wont really see the charging effect". The thing is I see a charging effect on the capacitors connected to pin 4. Thus I am surprised that this would be different from capacitors connected to pins 2 and 3

- "Using diode mode gives you a different reference point". I am sorry, I don't understand what you mean. I tried measuring conductivity by what I think is diode mode

- "You would have to remove the shield to check continuity up to those components." Can I do that without too much risk of damage? Can I put it back after?

- "start probing the PMIC output rails". Thanks for the suggestion. I tried looking for PMIC in the schematic but didn't find anything. Are there other names for what you have in mind?


The PMIC (PMU) is U48 in the schematic. Pin 4 (BATT_VCC)has a lot more capacitance on the line so that's why you see the charging effect. You said you measured resistance...that's not diode mode. Removing the shield exposes the board to more heat so you have to eliminate everything else before going to that next step.


Thanks for the very swift reply again!

I am not sure what are the next steps you suggest before removing the shield: where should I measure using diode mode?

Also, do you know if 1.20 V is low for pin 4 when adapter is plugged in?


Добавить комментарий

There are two inductors and a glass top regulator right next to the charge flex FPC, they chould have been physically damaged thus no charge

Block Image





Are all connected to BATT_VCC they are also very often go bad and pull BATT_VCC low

Check with multimeter

Block Image

Был ли этот ответ полезен?

Оценка 0

1 Comment:

Thanks a lot for your answer!

I will take a look at this. Off the top of my head, this is below the shield, right? Do you know if I can test this without removing the shield?


Добавить комментарий

Добавьте свой ответ

John Dupont будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 0

За последние 30 дней: 0

За всё время: 61