iBook G3 (Indigo / Firewire) booting to 1024x768

Anyone run into this issue before? I have 2 indigo iBook G3s, both models with FireWire. One iBook, we'll call it iBook 1, has been running 9.2.2 and 10.4.11 for well over 5 years from an 64GB SSD with no issues, and iBook 2 had the stock 12GB HDD. I decided to upgrade iBook 2's 12GB to a 30GB HDD. Before I swapped the drive into iBook 2, I used a FireWire case to clone iBook 1's SSD over to the 30GB HDD using CCC. I then booted off that HDD from the FireWire port on iBook 1. Everything worked great. I then put the 30GB HDD into iBook 2, booted it, it defaulted to 9.2.2. Everything worked great. So I booted iBook 2 into 10.4.11, I got the Apple logo and gray screen, but when it was time to load the login screen, the display went black (backlight was still on). I was able to screen share into it, and I saw that the system was seeing iBook 2's display as 1024x768 (which is outside the iBook's 800x600 range). I manually set it to 800x600, but nothing changed on the screen. I was able to use iBook 2's trackpad and keyboard as well, and sound was working fine, just that the screen was black. I then put iBook 2 in target disk mode and booted iBook 1 off of iBook 2's 30GB HDD. Everything was ok. I shutdown, then tried booting iBook 2 back into 9.2.2, but the same thing as 10.4.11 was now happening, once the 9.2.2 fully loaded (just after the happy Mac), the screen went black. I then tried to boot the 10.3 disk, and the retail 9.0 disk, and they too are booting to a black screen. I can access the boot menu just fine, see the start of a given OS loading, but then it goes black. I can remotely connect / screen share just fine, but the screen stays black the whole time. I did an PMU and PRAM reset, pressed the reset button inside iBook 2, swapped out the RAM, and booted without the battery. Nothing helps. I then booted iBook 2 back into target disk mode, connected it to my 12" PowerBook, repartitioned the drive (chose to install OS 9 drivers too), then did a clean install of 10.4.11, but it didn't work. I copied over another System 9 folder, that didn't work. Consistently booting to a black screen.

So I'm lost, probably spent 12-15+ hours on this so far. My theory is something in the hardware is reporting 1024x768, which the chipset on this iBook can't handle. Maybe there's a jumper tripped? It looks like 800x600 when the Apple logo or Happy Mac logo is on the screen, it's just that once the OS loads the graphics drivers, the screen goes out. My other iBook, iBook 1, is cruising along no probably this whole time. Firmware was updated to the latest version a long long time ago.

Thanks for any suggestions!

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 0
Добавить комментарий