Перейти к основному содержанию

27" display with 2560 x 1440 pixels resolution Thunderbolt & MagSafe cable attachments

139вопросов Показать все

27" Thunderbolt display turned off after a few minutes(Please help!)

Right, I am using the quite old display manufactured from 2011.

If you want to say buying a dell monitor, please ignore this request.

This symptom happened a while ago and I really tried to figure out why, but I couldn’t find out. Btw, thanks a lot someone who created this forum! I got a lot of knowledge.

So, the problem happens just after few minutes later. When I unplugged it and connected it again, it sometimes fixed. However, it never continue more than 30 minutes. I already tried to connect display from another thunderbolt from back panel instead of all-in-one cable. It works but never continued neither. I replaced the All-in-one cable and there was no change. I replaced the power supply unit with my another apple cinema display(not Thunderbolt display), but it didn’t work. I found out the PSU is the same with the Cinema display.

The things that I can try from now is

1. replacing logic board

2. AC Power Inlet.

Can anyone succeed to fix 27” Apple Thunderbolt Display ever?

I reached out to local repair shop, but they asked me around $400 for fix.

Please help me!! I don’t have money for buying $5-6000 monitor!!!!

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 1


When the screen turns off on its own take a flashlight and place it on the display at a sharp angle do you see a faint image of the desktop and your icons?


I cannot see any faint image or icons of the desktop. It seems like completely blacked out. As I explained, it works as normal after I re-plugged while minutes after. I have no idea what the problem is.........


Добавить комментарий

2 Ответов

Наиболее полезный ответ

This is almost always a capacitor issue on the power supply board or controller board - doesn’t matter which monitor you have. It can be repaired, but you probably need to replace all of the capacitors in the monitor.

The LED monitors have fewer failure points then the CCFL monitors they have since replaced, so it’s generally a capacitor issue on these if you have ruled every other practical possibility out as not being the issue. You will need to do a teardown of the monitor to fix this issue.

Refer to this guide to remove the power supply and controller boards for recapping. Practice on a junk board first if you have never soldered before, since a mistake with a soldering iron can (and usually does) mean the end of the damaged board.

Update 6/12/19

Here is the controller board:

Block Image

The capacitors on the controller board are going to be SMD as there are no through hole points that indicate that they’re through hole. You will need to use a hot air gun to get these off, as a soldering iron tends to not work very well. I do not have the values, but you can get them off of the capacitors or a reference board.

Был ли этот ответ полезен?

Оценка 1


Thanks for your comment! I had replaced the power supply unit with my another Apple cinema one, but it didn't work. So, my question for you is what is Controller board? I know how to disassemble and re-assemble with new parts, but I don't know how to solder iron. And what is Capacitor in controller board? Perhaps PSU itselt is not the issue neither I think because the Apple cinema one didn't work. Again, thanks for your kind explanation! Look forward to hearing more from you!


I'll add more information later, but I've added a photo to ID the controller board. For now, the thing to remember is both boards have capacitors and that may be the fault.


Aha! That makes sense. So what are capacitors? Where should I solder? I am afraid to do it, but I just want to know. :)


I added more to the answer.


I saw your red mark, yet it is hard to understand what are capacitors. Do I need to solder entire irons there? Or do you think that buying and replacing the logic board will fix this issue? Thank you for your quick reply, Nick!


Показать 2 больше комментариев

Добавить комментарий


since you cannot see any images with a flashlight shining at an angle against the screen it does not appear to be the backlight (common for this model would be bad backlight LED’s). “it works as normal after I re-plugged while minutes after “ rules the power board pretty much out as well. My suggestion is a new Thunderbolt cable. Then re-evaluate.

@archinspace post some good pictures of your boards with your question. that way we can see what you see Adding images to an existing question

Был ли этот ответ полезен?

Оценка 0


@oldturkey03 - FYI: ' I replaced the All-in-one cable and there was no change."

Got to be something on the logic board that's flaky - Cap?


@danj nope. Would not come back on just because it got reconnected. I still think it's most likely cable related. :-)


@oldturkey03 - I've seen tantalum caps breakdown as they cycle a few times.

He also used a TB cable into the ports bypassing the combo cable and that also removes the onboard TB connector on the logic board as well.

I would focus on the logic board checking the solder joints and well as the caps.


Thanks for all comments, all. Sorry for late come back. I tried to use TB cable directly from the back panel and it is still not working. So, I don't think the cable is the issue.


Добавить комментарий

Добавьте свой ответ

Sean будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 12

За последние 30 дней: 38

За всё время: 1,003