Перейти к основному содержанию

Отремонтируйте ваше устройство

Обучение ремонту

Магазин

Monitor no signal after upgrading

So I recently upgraded my PC, a Dell Inspiron 5675. I upgraded the GPU to an RX 580, the CPU to a Ryder 2700x, and the PSU to a EVGA 650w silver power supply. It looked fine and seemed to work fine, until I actually tried turning on the monitor. It acts as if there’s nothing there’s and keeps saying No Signal. I’ve tried reseating my GPU multiple times, replacing it with my old one, and putting it in a different slot on the motherboard. I’ve tried a different monitor and different cables, but that has the same result.

Отвечено! View the answer У меня та же проблема

Это хороший вопрос?

Оценка 1
Добавить комментарий

SKIP THE UPGRADE

Save by fixing with an all-in-one kit.

Shop iPhone Fix Kits

SKIP THE UPGRADE

Save by fixing with an all-in-one kit.

Shop iPhone Fix Kits

1 ответ

Выбранное решение

Try putting your old CPU back in. The new CPU you got might be dead.

More things than the GPU can cause no signal. If the issue persists when you put the old CPU and even GPU back in I would try a CMOS reset (depends on the motherboard, but it looks like the jumper for resetting it is right by the coin cell battery in the lower right hand corner of the motherboard).

If none of this helps, the new PSU might be at fault. Worst case scenario, you end up completely undoing all that you changed and see if it works then. Then you can start replacing components with the new ones until it stops working again.

If you could take a picture of that header by the battery, that would be super useful.

Был ли этот ответ полезен?

Оценка 2

Комментарии:

It turned out to be the CPU, I don’t think you understand how helpful this was thank you. I’m going to try to reseat the CPU later and if that doesn’t work get it refunded. Thank you very much. (I also attempted a CMOS reset before but I don’t think it helped.)

из

@Toddu 111 You're welcome! I'm glad I could help :)

That's a shame that the CPU is dead, I really hope you can get it refunded/returned.

из

Hi,

It may be that the CPU is not dead it just may not be compatible with the motherboard.

Found this link which might explain the reason why.

из

Ah, that's a good point, the motherboard may not be compatible. I didn't think of that at all. I kinda forgot that there have already been several revisions of Ryzen.

из

Добавить комментарий

Добавьте свой ответ

Toddu 111 будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 0

За последние 30 дней: 2

За всё время: 119