Перейти к основному содержанию

1.8GHz dual-core Intel Core i5 (Turbo Boost up to 2.8GHz) with 3MB shared L3 cache

349 Questions Показать все

Fan spin at high speed, boots albeit very slow

A couple of weeks back I accidentally spilled half a cup of water on the keyboard of my mid-2012 MBA (820-3209A, as far as I’ve found out). I reacted quickly shut it off, turned it upside downand let it drain off.

It’s currently in this state:

boots normally, but upon loading the fan revs up and it works extremely slow. Boot up takes several minutes. Cursor movement is laggy and unreliable, keyboard input as well.

Booting in Diagnostic mode reveals error code «4SNS/1/C0000008:THSP--124»

I’ve dismantled the battery, logic board and I/O-board, dustef it off with a tooth brush and removed any sign of unwanted particles. There were no signs of liquids inside, nor any obvious corrosions except for a green’ish layer of gunk on one of the pins on the socket of which the battery connects to the logic board.

Having seen a lot of instructional videos online, as well as googling all similar error codes on this model, I am still in the dark to what could be the issue. I am also insecure as to this being a I/O card problem, or if it’s related to the logic board.

As far as I’ve understood, «4SNS» means «Sensor», and «THSP» means «thermal» and «Hard drive». I’ve also read somewhere that the error code I’m getting points to the Thunderbolt Proximity Sensor. I’ve tried looking up the logic board in openboardview, and paid special attention to the Q5520, Q5530 and Q5540 chips. They’re hard to inspect due to their small size, but they do not come across as harmed.

Could someone give me some tips as to where to look, what to look for etc? I live out in nowhere without anyone to ask for help, and since it was my own %#*@ fault I got in to this pickle, I’d prefer to fix it without travelling to the city and have a Genious look at it. I work in IT, but apart from chipping a couple of gaming consoles back in my youth, soldering is not my strongest skill. I’ve got a multimeter, but no training in using it apart from making it «beep» when the trail is not cut off.

What I have tried:

  • Booting without integrated keyboard, only external (in case integrated was defective)
  • booting without SSD attached
  • booting without battery attached
  • dismantling and inspecting/dusting/cleaning and then reattached everything

If anyone wants pictures of something particular, let me know what parts I should do photos of.

Sincerely,

blodfjert

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

по рейтингу 0
Добавить комментарий

Android Fix Kits

A new screen or battery is one kit away.

Купить сейчас

Android Fix Kits

A new screen or battery is one kit away.

Купить сейчас

1 Ответ

THSP— 124 is Thunderbolt sensor

Your logic board is in need of repairs.

Update (08/08/2019)

The Thunderbolt chip is the one outlined in Yellow

Block Image

Был ли этот ответ полезен?

по рейтингу 0

Комментарии:

Ok, could I possibly ask you - or someone - to point out this sensor on an image for me? I’d really like to see exactly what chip it is, so I could inspect it and see if I could somehow solve it :)

от

Добавить комментарий

Добавьте свой ответ

Blodfjert будет вечно благодарен.
Просмотр статистики:

За 24 часа: 0

За 7 дней: 0

За 30 дней: 0

За всё время: 14