Перейти к основному содержанию

Apple's line of laptops for professional and power users. To date, the MacBook Pro line includes 13, 14, 15, 16, and 17-inch variants, with major revisions defined by Pre-unibody(Original), unibody, Retina display, Touch Bar, and SOC (system-on-a-chip) designs.

20104вопросов Показать все

Strange Power Supply Behaviour

I have an early 2011 13” Macbook Pro that is exhibiting unusual power issues. On the surface, it seems like a common problem: Mac won’t turn on when magsafe is connected, battery is missing when it turns on, fan runs at full speed, etc. The solution typically is to reset SMC and PRAM. I have done all this and more and this question is about the issues that I have not been able to figure out after three days of researching this problem.

When the magsafe is connected, it goes green immediately and the front sleep led starts blinking periodically. Power button does nothing. I opened the back of the machine and discovered that the fan basically starts spinning when the magsafe is connected, but it does not receive enough power to actually boot up.

The correct SMC reset procedure, cmd+option+shift+ power button does not seem to do anything. However, the old procedure, unplug the charger and hold power button for 10 seconds, connect the charger while continuing to hold the power button for 10 seconds, release, works. The computer boots as soon as I release (I do not need to press power again, it just boots), but now the fan is at max speed, and the battery is not detected at all. I was running Lion, and discovered that El Capitan would fail with installation errors and Sierra would tell me that the power supply needs to be connected (though charger was already connected).

The breakthrough was when I messed around with the battery. After a day of experimentation, I have found that I can consistently boot up with the following procedure:

Unplug battery

Unplug Charger

Press and Hold Power Button to discharge any residual power

Connect Charger - Green light comes on

Wait for the fan to start spinning up automatically (power is never pressed)

When the computer fails to startup and fan starts spinning down, plug the battery in

On next spin up cycle, the machine now will successfully boot.

Fan runs at normal speed.

Battery is detected, but does not charge.

Magsafe remains Green.

Coconut Battery reports that the battery is in good condition.

I managed to update to Sierra without any issues.

Pushing the battery indicator button on the left side leads to a single flashing green light for five seconds.

HOWEVER, about a minute after the machine boots, it CRAWLS. Kernel Task runs constantly and consumes all of the CPU power. Machine runs super cool because of the extreme thermal throttling.

If I shutdown from this condition, the machine again fails to power up and I have to repeat the procedure. However, the fan continues to constantly spin up, meaning the machine is constantly trying to power up unsuccessfully. I left it alone in this state for 30 minutes and discovered the bottom was quite warm, which means certainly a lot of power was being pumped thru the board, even though it was not booting up.

I am unsure what my next diagnostic move is. I figure I need to get another mac to check the battery and the charger first. If those two are cleared, then the problem is hopefully just the DC board, BUT also possibly the mainboard? Beyond the battery and charger, I am not sure what else I can check. Any advice is appreciated.



Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка 1
Добавить комментарий

Ответов (3)

Выбранное решение

Your many troubleshooting attempts show that you can start your Mac in SMC bypass mode, thus you’re left wit two basic possibilities:

  • Bad battery
  • Bad SMC or related circuitry.

Disconnect battery and see how it goes. If everything gets back to normal without it just replace battery, regardless of the apparently “good” condition.

If problems are still there with battery disconnected you have a board issue requiring component level troubleshooting and repair.

Был ли этот ответ полезен?

Оценка 4

28 Комментариев:

Thank you for your reply. Observations without battery as under:

1) Removed battery, tried to perform SMC Reset (cmd+shift+option+power button) and power on. Does not work. Once the charger is connected, the machine is clearly trying to startup but not getting enough power and dies. If I had to guess, it seems the charger is "leaking" current into some capacitor that triggers the boot-up sequence, but there is just enough current to spin up the fan and DVD drive and it dies. Process repeats when the capacitor gets enough juice to do it again.

2) Removed battery, disconnected charger, held power button for 10 seconds, connected charger while still holding power button for 10 seconds, released power button. Machine boots up, fan at max speed, no backlight for keyboard, everything else seems to work. I expect Sierra installation will fail because it will not recognize that the machine is plugged into the mains.

This seems to be a board problem. But is it the DC board, or the mainboard?


Also, for this machine, the correct SMC reset procedure is the cmd-shift-option method. That does not seem to make any difference. However, the hold power button method works, so I wonder, what exactly is that doing? Is that a "bypass" feature, rather than the "reset" feature?

And when I do the hold power button thing, even after shutdown, the fans do not keep spinning, the machine seems to stay off while charger is connected. That seems to put my "current leaking into capacitor" theory out. Still very confused how to make sense of what is going on here.


@karthikrr The correct SMC reset for your machine is shift+ctrl+alt+power pressed together with battery and magsafe connected. There's no such thing as "leaking current into some capacitor that triggers the boot-up sequence" happening, you likely have an SMC circuitry failure that needs component level troubleshooting. Unless you have the necessary skills and tools I'd not advice investing further time into it, it won't get you anywhere.


@arbaman ctrl, not cmd, yes. I did it right, but I am a Windows user, not a mac user, and I always get confused when talking about this :) (the machine I am working on was given to me by a friend who said it was too expensive for him to bother fixing)

No current leak, got it! Okay, so certainly a board problem and beyond my abilities, this is very useful. I will push it up the ladder to a professional then. Thanks for taking the time to reply.

One last question though - what does the "press power button without charger, connect charger, continue pressing power button" do? It is clearly not the SMC reset procedure for this model, BUT it works and boots the machine. Does this "bypass" the SMC? All the symptoms of a bad SMC are still there, fan on full speed, no backlight, battery not detected. I am curious to know what is happening in this method.


Hmm, I just installed Ubuntu to see if I could get any more insights. When battery is connected and detected, Ubuntu shows the CPU frequency at 800MHz. I thought CPU throttling was a Mac OS thing, but apparently not?!

When battery is disconnected, CPU runs at full speed along with fan also on full speed.

Also, this is supposed to be a 2.7GHz i7. Ubuntu says its max frequency is 3400MHz. Does this matter?


Показать 23 больше комментариев

Добавить комментарий

@karthikrr karthikrr , I have been facing similar issue on my macbook pro 2013. Not Booting and No display

Do you think it’s related to DC in Board ?

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

Try unplugging the battery for 5 minutes then plug it back in, it worked for me.

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

Добавьте свой ответ

Karthik Raghavan R будет вечно благодарен.
Просмотр статистики:

За последние 24 час(ов): 4

За последние 7 дней: 10

За последние 30 дней: 27

За всё время: 2,929