Перейти к основному содержанию

Отремонтируйте ваше устройство

Обучение ремонту

Магазин

2.26 or 2.4 GHz / White plastic unibody enclosure

763вопросов Показать все

Late 2010 MacBook Unibody not powering on...

Hello everyone, I have a Late 2010 Macbook Unibody A1342 that I am trying to resurrect. It was running MacOS High Sierra, 16GB of RAM. I let the battery go too far without replacing it and the computer no longer powered on even with AC adapter plugged in. I know, lapse in judgment.

  • I ordered a replacement Newertech battery and decided to upgrade to an SSD hard drive at the same time.
  • Tried to power on after installation and nothing happens.
  • Magsafe light with the original AC adapter would not come on at all…first I tried another AC Adapter that I knew was working from another computer and the Magsafe light glowed green, but does not change to amber to signify charging is occurring.
  • Tried following the procedure for resetting the SMC many times to no avail….tried with the battery in and without. Still no power on.
  • Reasoned that it my be the Magsafe DC in board that was faulty….replaced it, still only the green light on the Magsafe cable when connected to the computer.
  • Tried “shorting” the power pads on the logic board as a last resort while the Magsafe AC adapter was connected to computer in an effort to power on. Nothing.

I don’t know if there is anything else to try other than replacing the logic board. Any advice?

Отвечено! View the answer У меня та же проблема

Это хороший вопрос?

Оценка 0
Добавить комментарий

1 ответ

Выбранное решение

Mauricio, if you have a voltmeter, measure the voltage across the same pads you shorted. Should read battery voltage in the “off” condition. Is any change detected when you press the “start” switch? (The green light on the charging Magsafe connector indicates no charging current flow, i.e., the battery is fully charged.) I had this problem; turned out to be a defunct “start” switch, but shorting the power pads got things going, so…

Был ли этот ответ полезен?

Оценка 0

Комментарии:

Hi Doug,

Voltage does read off. No change when “start’ switch depressed. I tried shorting the pads with the keyboard ribbon connector disconnected to try and isolate the problem by eliminating the keyboard/power switch as a variable. Still nothing. Do you think it could just be a dead logic board?

из

Добавить комментарий

Добавьте свой ответ

Mauricio Rebolledo будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 0

За последние 30 дней: 0

За всё время: 33