Перейти к основному содержанию

Model A1286. Released February 2011 / 2.0, 2.2, or 2.3 GHz Quad-core Intel Core i7 Processor

665вопросов Показать все

MacBook had power adapter disconnected for 3-4 months, now won’t boot

Hi everyone,

so I got a MacBook Pro a year and a bit ago and it was working beautifully. I’d disabled the Radeon card as I’ve heard the horror stories and had no issues doing the basics. 

the last few months have been crazy and I haven’t touched it, at some point the MagSafe connector got bumped off. I came to it today, saw that and reconnected it. The light went from orange to green pretty quickly and I tried booting it, no luck. 

I pressed the battery indicator hoping to get a status and it blinked 5 times, which with no knowledge of anything struck me as a bad sign. 

I tried a batch of troubleshooting tricks. Reset SMC - no go. Leave it to charge for a couple hours, also no dice. The closest I’ve come to figuring stuff out was a trick I found that had me holding the power button down and while doing so plugging the MagSafe back. I got the boot up screen and sound, fans were going 100% and the progress bar on the boot screen started to move. This was disappointing as it got to 50% and the system shut down and went into a perpetual boot loop. 

I know from the previous owner that he had to get repairs done for the Radeon issue and I’ve made sure to run the integrated video card ever since I got it and keep it as cool as possible. He also identified that the battery even with relatively few charging cycles didn’t keep the system running for long which I didn’t care about as I exclusively use it plugged in. 

but alas here I am now. Because of its age I don’t really want to sink a fortune into it. I’d be okay doing a battery swap but even $120 (Canadian) is a hard pill to swallow for a device that I don’t use with any real frequency. 

that said I really don’t want it just to go to recycling, I would love to have it as a secondary machine - thanks in advance for any help or advice.

Update (09/05/2019)

Okay first I want to thank everyone for their replies.

I’ve tried a trick to see if I can get the Mac to boot assuming the issue was with the battery.

I’ve disconnected the battery and did the same trick as I had before, hold the power button for 10 seconds, plug in the MagSafe connector, release the power button and it started to boot like it did before I removed the battery.

the system goes into a boot loop like before. The progress bar gets halfway and then the system does a full restart, repeat ad nauseum

Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка 0


How did you disable the graphics chip?


I used Steve chow’s fork of gfxstatus

It still will ping the discrete chip during some system events and on boot, but the chip mostly works for the time being so I’m not too stressed

Also installed a different fan management program (Macs fan control) to keep the temps as low as possivle


Добавить комментарий

2 Ответов

Выбранное решение

So an update - it was the battery! Took a chance and picked one up off amazon, popped it in and all was good!

used dosdude1s patch and am rocking Mojave! I tried Catalina but there’s no support for the continuity activation tool and I couldn’t get the discrete card to turn off. I know I can use some kext mods to turn it off but I don’t wanna go down that route. At least I’m one step more current!

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

I used to have the same MacBook Pro and I had a similar problem. I once plugged in a USB cable and the MacBook Pro just shut down and went black and showed no signs of life at all. After trying several things, including SMC reset, nothing helped. Then I simply just opened up the computer, unplugged the battery, plugged it back in, and it booted normally. I’d say give that go as it is easy and free.

But yes, I no longer have that computer because of the dreaded AMD Radeon graphics problems. I am curious on how you disabled the chip though…

Был ли этот ответ полезен?

Оценка 0


I was really hopeful after reading this comment so the first thing I did after I got my kids off to school was to do this, alas no luck I’ve updated the post with the full details sigh


Okay small update. I tried booting and selecting the hard disk.

got it to boot, connected to wifi, selected the main hard drive and the progress bar did its thing and as usual rebooted halfway through as before

Then I tried booting into safe mode by holding down the shift key, this ACTUALLY worked!

So I am able to boot but I can only boot into safe mode, I tried restarting afterwards but got nowhere, so I’m not entirely sure where to go from here? Do I just do a full reinstall? Do I snap up a new battery and reinstall the system?

I’m thankful there’s progress but I’m concerned that it’s not enough to get the system up and running


@andsoitgoes What I would do personally is back up all my files, use Disk Utility to completely wipe the HD, reinstall MacOS, and move all my files back over. That’s what I would do but I also have all the tools to do it. I have an external HD that I can boot from, wipe the HD, and reinstall from . But I wouldn’t recommend just doing a Time Machine backup because that includes all sorts of extra files in your user’s Library that could be causing the problem.


Добавить комментарий

Добавьте свой ответ

Nick будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 0

За последние 30 дней: 0

За всё время: 40