Перейти к основному содержанию

2.26 or 2.4 GHz / White plastic unibody enclosure

645вопросов Показать все

My MacBook 2010 restarts immediately when I shut down

Have a Macbook 2010 unibody that restarts when I shut down via Apple Menu. I can shut down only by pressing the power button for several seconds, then it forces shutdown. This happens whether on power adapter or on battery power.

Also, if the power adapter is disconnected after a hard shutdown, the Macbook starts up immediately when I connect the power cable.

I have tried different RAM. I have installed and reinstalled both Yosemite and El Capitan. I have also changed hard drives.

And…. I don’t know if it’s connected to the problem or not, but after a few reboots the AIRPORT card is no longer recognized; it’s as if it isn’t installed. Not available as an option under Networking. A few times there was the Airport icon in the Menu Bar, with an X thru it, but now there isn’t even the icon.

What’s odd is that the Macbook has a Airport/Bluetooth card all in one, and Bluetooth works perfectly. Maybe I accidentally disconnected the Airport cable?

Thanks for any help.

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 1
Добавить комментарий

1 ответ

This is a total shot in the dark, but have you tried to reset your SMC?

Also what happens when you remove the battery and connect the charger, and then run off of the AC adapter alone? Does this solve anything?

Basically if you can isolate the issue down to either the battery, the logic board, or the SMC, then we’d all be closer to figuring out what the issue is.

I’ve never encountered anything like this, however, so I’m not sure how to help other than just isolating the problem and narrowing down the culprit.

Был ли этот ответ полезен?

Оценка 0

2 Комментариев:


I reset the SMC and PRAM.

I changed the RAM and the hard disk.

I reinstalled the OS.

I’ll try a different battery and/or detach the one in there now.

Maybe the PRAM battery?

The strange part is the Airport card “disappearing”, which happened in 2 steps: first, there was the icon with an X thru it in the Menu bar; then, no icon at all. While Bluetooth works fine.


I would still try to remove the battery and see what comes of that. It might help eliminate the potential for a bad battery. In all honesty your machine is so old that I wouldn't be surprised if it was a board fault but let's hope it isn't.


Добавить комментарий

Добавьте свой ответ

Matt будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 0

За последние 30 дней: 0

За всё время: 58