Перейти к основному содержанию

Released by Samsung in March 2016. Model SM-G930.

Вопросов 428 Показать все

Custom blocked by FRP lock after update on android

Hi ! I got a Galaxy S7 (SM-G930F) and when i was using my phone, it told me that an update was available. I did agree to install it, and then my phone downloaded it and rebooted. But during the update, i got an error message at 32%, (see attached picture)

Block Image

and then my phone rebooted and says “custom binary blocked by FRP lock”.

Can anyone please help me, because i did not know what i’ve done wrong. I already installed updates in the past when my phone told me that they were available, but this time it did not work… :(

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 5
2 Комментариев

Ntt docomo custom blocked by frp



This is exactly what happened to me!!


Добавить комментарий

Ответов (2)

Наиболее полезный ответ

I'll give you some info to put you in the right direction.

So basically what happened is that the phone had a custom binary flashed on it which is at the very least a custom Recovery or Root file.

Now since the phone is displaying Custom Binary Blocked by FRP lock there is no way around it without reflashing latest original stock Samsung Firmware and doing a factory reset on the phone.

If you want to keep data you'll need to take the phone to a reputable phone repair shop that utilises GSM box (flash / unlocking) boxes as they can unbrick the phone without resetting it.

For the flashing part make sure firmware being downloaded is the latest one. Always check via Sammobile with model no of phone e.g SM-G935F. And the CSC which is a 3 letter sales region code that is displayed usually on the download mode screen as Carrier_ID.

To get into download mode you simply hold power, vol down and home until you get the light blue screen with text prompt. Follow instructions to enter download mode.

Make sure to use latest Odin so that latest OS firmware is compatible with flashing program.

Sammobile has download (DL) link for Odin when firmware is selected to prepare download.

Best way to DL firmware is to use the SamFirm application from XDA Developers forum thread, when you google search that app you'll find it.

If you get SW Rev check fail Bin:x SW: X it means firmware flashed is too much older than the current firmware on the phone. To fix that simply flash newer firmware. You'll need to re-enter download mode to flash again.

Был ли этот ответ полезен?

Оценка 4

4 Комментариев:

Great answer, I'd upvote it twice if I could :)


Hi, there and thank you for your answer.

So i downloaded Odin3_v3.13.3 and the G930FXXS5ESF8 firmware using SAMFIRM, wich is normally the latest version of Android 8.0.0. for the Galaxy S7

I tried to flash it, but i got the “SW REV CHECK FAIL (BOOTLOADER) DEVICE 6, BINARY 5”

It’s strange because this is the latest version of Android i’m trying to flash.

Any advice ?



The 5 in the firmware name is the binary bit of the firmware. Since it is 5 and the device binary bit is 6 it will not work.

The problem is probably something to do with which region firmware you are downloading. While it is not necessary to have the right CSC code you can use firmware from different regions if needed.

Download another firmware but make sure this time it has 6 in it or higher.

XXS seems to be chosen region code, try another firmware region preferably in same country. Sammobile shows list of CSC codes so check up to see which regions have binary 6 firmware or higher then use SamFirm accordingly to download it.


Thank to you, it works again ! You were right, because i was trying to install the XFE firmware wich is : G930FXXS5ESF8, without succes. But when I follow your advice and tried with that one : G930FXXS6ESGD it worked like a charm !

So thank you so much, both of you for answering me and guiding me on the right path to repair !

Edit : I've noticed that the firmware of the network provider (Orange) is also a 6 binary bits one (G930FXXS6ESGD), but since the previous one worked, i won't change it =P


Добавить комментарий

You can bypass Google account screen on your Galaxy A8 but first you need to know what version of Android is installed on your phone. You can find it the Android version in by booting into recovery mode.

Once you find the version, now search in Google or I would prefer YouTube with something like this “Galaxy A8 2018 Android 8 or 9 bypass”.

You’ll get many tutorials on how to remove Google account.

One problem though is, Samsung is releasing security patch update to these bypass methods that may not work for you. In that case you can also try an FRP Unlock Service that can bypass it within 5 to 10 mins but that downside is these services are paid.

Once service that I would highly recommend is by Progeeksblog.com they have amazing service as well as 5 stars ratings on Trustpilot.com.

Here is the link: https://www.progeeksblog.com/samsung-frp...

Hope this helps.

Thank you

Был ли этот ответ полезен?

Оценка 0

1 Комментарий:


I wanted to ask if my Samsung s7 android 10s shows custom binary frp lock and always restarts. Please help...


Добавить комментарий

Добавьте свой ответ

Donatien DELCROIX будет очень признателен(а).
Статистика просмотров:

За последние 24 час(ов): 3

За последние 7 дней: 7

За последние 30 дней: 46

За всё время: 2,536