Перейти к основному содержанию

Mid 2012 model, A1278 / 2.5 GHz i5 or 2.9 GHz i7 processor.

1577вопросов Показать все

Why is this thermal sensor acting crazy?

I have a mid 2012 13” MBP that I purchased back in December 2014. In 2017, the system started giving me serious kernel_task problems. The process used to jump over 300% even during idle time and the laptop became unusable. Doing some diagnosis gave me this error:

4SNS/1/C0000008: TAOP—124

Which I decipher as a faulty temperature ambient air optical drive power bus sensor. I also have the schematic for the A1278 logic board that this system works on and so I can approximately locate the location of this particular sensor. However, not every time my system is running the way I’ve described above. For example, during writing this question, I experienced lag a couple of times but also normal functioning side-by-side. Which means that the sensor is not 100% dead. It does work but something is not allowing it to work at full capacity. Also, there are so many sensors on the logic board, why did this particular sensor throw out the error?

As of my own experience, cleaning some dust a couple of days ago put my system to normalcy and I thought I fixed the issue but now it’s here again, sometimes working and sometimes not working. I’ve never spilled liquid so that is not the cause; maybe some moisture that I cannot avoid. What would subject the sensor to function randomly and can it be fixed?

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 0
Добавить комментарий

2 Ответов

Наиболее полезный ответ

Sounds like you had liquid spill into the trackpad at some point and the ribbon connection is corroded which is messing up the sensor on the logic board.

I would try replacing the trackpad MacBook Pro 13" Unibody (Mid 2009-Mid 2012) Trackpad and here’s the guide MacBook Pro 13" Unibody Mid 2012 Trackpad Replacement

MacBook Pro 13" Unibody (Mid 2009-Mid 2012) Trackpad Изображение


MacBook Pro 13" Unibody (Mid 2009-Mid 2012) Trackpad


Был ли этот ответ полезен?

Оценка 2

5 Комментариев:

I’ll have to look if there’s some corrosion. Helpful answer!


So basically the culprit is either the track pad or the optical drive.


Optical drive? Not likely.


Makes sense. I’ve never used the optical drive but I like keeping my things clean. Often, the trackpad would gather some of the sweat from my fingers that I used to wipe with some Colin. And I think that has done some corrosion to the cable although checking it today didn’t give me the impression that there is any damage to it.


If you are directly spraying the cleaner onto the uppercase it can creep in! Over time it can damage the trackpad as well as the connections.

I always recommend spraying the cloth and then wiping the uppercase.

Time for a new trackpad - Sorry ;-{


Добавить комментарий

Which means that the sensor is not 100% dead. It does work but something is not allowing it to work at full capacity. Also, there are so many sensors on the logic board, why did this particular sensor throw out the error?

Not 100% dead is another way of saying it’s barely alive! The thing “not allowing it to work at full capacity” may well be the very fact that it is failing.

As for why that particular sensor, who knows? It might just be the first failure. But if what you say is correct, and it’s related to the optical drive, then it’s probably very close to (or inside) the optical drive, which is one of the worst spots to be in in terms of ingress particle/liquid protection.

I don’t have the schematic or boardview for the pre-retina MBPs, but if sensor in the optical drive, built into the cable, a separate thermistor, etc., you might be lucky enough to fix this by replacing the optical drive, ribbon cable, or the sensor itself.

It may also be just a SMC config issue, but I’m guessing you’ve already tried an SMC reset.

Otherwise, unfortunately the only other option I can think of at the moment is an MLB replacement, assuming you don’t want to do an SMC replacement. You don’t, and you probably won’t be able to find anyone willing to do it for you either.

The thing is though, the only practical issue you’re having is the unnecessary thermal throttling by kernel_task due to the failing sensor right? If that’s the only issue, and removing the optical drive and/or its sensor doesn’t help, you could get away with just disabling the kernel power management. Just remove the kext that handles your board id or rename it to something else (e.g. IOPlatformPluginFamily.kext to IOPlatformPluginFamily.kext.tmp, invalidate your kernel cache, and that might fix the problem of kernel_task hogging all the system resources in an effort to prevent the non-existing overheating condition.

Был ли этот ответ полезен?

Оценка 1

2 Комментариев:

That was very helpful. I’ll check investigating the drive for some time.


Actually, that interpretation of the AHT code is probably inaccurate, for one thing "temperature/ambient air/optical drive/power bus" isn't meaningful at all. Are you sure it wasn't TA0P, 0 not P? Take into account only the first two letters as usual and it makes a lot more sense. I tried to follow using schematics for a 820-3115-B board, is that the one you have? I'd check the whole board for corrosion especially around connectors and cables including the debug connector if there is one. And one last thing, try running AHT from the 2nd dvd that the machine came with, and see if that gives a different code.


Добавить комментарий

Добавьте свой ответ

Shivendra Sharma будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 2

За последние 30 дней: 5

За всё время: 311