iPad Pro 12.9" Sleep/Wake not working after screen repair

I repaired a screen on an iPad Pro 12.9” 1st Gen (a1584) and after the repair, the power button works on long-press to turn on the device, but once the iPad is on, short press does nothing (no sleep/wake) and long press does not work to bring up the shutdown option. I’ve tried with 3 different display assemblies (all confirmed working) as well as now with the original display assembly and that functionality seems to be nerfed independent of the part. I have inspected the power/vol flex and see nothing that appears creased or damaged, I have done a thorough visual inspection of the board and can find no obviously fried components or traces. The battery was isolated for the duration of the repair, so I am now at a loss. I’ve experienced this issue before with the iPad Mini 4 and the Air II, but with those, the problem is usually the magnetic induction flex coming improperly soldered onto repair parts. In those cases, a quick rework of that flex fixes the issue. In this case, I cannot for the life of me figure out what is causing this problem. Has anyone experienced this or have any troubleshooting tips?

EDIT: forgot to mention- first display assembly that went onto the iPad came with the daughter board attached. The second display I tried (also confirmed working on a separate device) I soldered the original daughter board onto it to rule out the possibility that changing the daughter board created the problem (as I said, previous experience with repair parts arriving with problematic soldering work led me to wonder if that was causing the issue) but no luck. Third display is using a replacement daughter board again. All combos of daughter boards/displays return the same result, so at this point I am certain it is not parts related.

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 0
Добавить комментарий