Перейти к основному содержанию

The Western Digital My Passport Ultra is a USB 3.0 portable storage device with capacities from 500 GB up to 5 TB.

37вопросов Показать все

I can't always see My Passport and when it happens it doesn't work

Hi guys, i know that’s a common topic and i wouldn’t have opened another question about this external drive, if it didn’t work at all.

The strange thing is that most of the time i can’t see the image (70% of the time i plug it), but sometimes it shows on the Desktop. When this happen, if i’m lucky i can see all my files but if i’m not, i can see this loading page or just a part of them (like 5 folders on 15).

In the afternoon i’ve tried to copy on my Mac a folder with lots of pictures (10GB): it started, arrived to 500MB, then it stopped for 30 seconds, arrived to 700MB, stopped again until it reached 2GB and then an error message appeared.

Sometimes i can also listen the famous “click” but it doesn’t happen all the time.

Finally, when it’s mounted if i try to eject it, it always appears the windows for a forced eject.

Forced eject and the loading page screenshoots.

Block Image

Block Image

Is there anything i can do? Thank you all.

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 1

7 Комментариев:

connect to a different USB port. Newer drives need more electrical power. Ideally get a good *quality powered* USB.

Do not get a cheap one - will kill both your laptop and mypassport


I've already tried to connect to a different USB or PC. I have also tried to replace the driver or change the usb cable. But it's always the same thing.


What operating system are you running?


@mayer It’s MacOs Catalina 10.15.3


@danj has a better handle on the problems of APFS formatted drives conversing with standard GUID formatted drives, so maybe he can answer this better than I.


Показать 2 больше комментариев

Добавить комментарий

1 ответ

Sadly HDD’s are sensitive to bangs and drops. Did you by chance bump it while it was plugged in? The best way to think this is like an old phonograph disk player (if you ever even seen one). Dancing or jumping will often cause the disk to skip! If you drag the arm across not lifting it you can damage both the needle as well as the disk. My sister did that to my favorite disk just for spite years ago ;-{

Sadly HDD’s are very similar the heads can get damaged as well as the disk platers them selves. In addition they have a motor which needs to spin up during that process the head assembly is released from its locked position. The clicking sound you are hearing is the head lock trying to release. Sometimes they stick, as a very last resort a flat bang straight down from a few inches might be enough to free it. Again this is the very last thing to try if you can’t get the drive to respond.

In any case I would copy off my stuff ASAP! As you may only get a few more attempts to get to your stuff! WD did offer a lifetime warranty see if you can get a replacement from them.

Был ли этот ответ полезен?

Оценка 0

1 Комментарий:

Thank you guys for all your replies. No i didn't bump it. There's only one strange thing that happened in the same day that i found it broken (?).

I have a Macbook Pro that i never turn off from the first day i bought it (2014). In the last months My Passport was always connected to the Mac, but the other day i have used the computer in the morning and in the afternoon without any problem; then, after my dinner i came back to my room, and i've noticed that Macbook was restarted. In fact, after the login page appeared the usual pop up for the unexpected restart; so i guess there has been a kernel panic but idk if it's correlated to the My Passport problem.


Добавить комментарий

Добавьте свой ответ

Alfonso будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 3

За последние 30 дней: 21

За всё время: 478