Перейти к основному содержанию

27" display with 2560 x 1440 pixels resolution Thunderbolt & MagSafe cable attachments

143вопросов Показать все

Replaced power supply, power to magsafe but not displaying.

Hi there,

I recently acquired a Thunderbolt Display model A1407 that I was told had a blown power supply. After seeing reports that a power supply could be replaced to regain full functionality, I decided to order the part and replace it.

After replacement, the interconnect cable delivers a charge to the magsafe cable into my MacBook, but does not display an image or appear to power on when I connect the thunderbolt cable.

I have a spare interconnect cable assembly to attempt to replace as well to see if that might fix the problem, but wanted to reach out to see if anyone had any other suggestions.

I picked it up in parts, so it's by word that it was in working condition before the supposed power supply issue.

Any other thoughts or suggestions for me? I'll probably be more careful in the future about picking things up for parts, but it was a good excuse to buy a nice toolkit from here that I'll be able to use on all sorts of other stuff.

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 0
Добавить комментарий

1 ответ

Наиболее полезный ответ

Do you have a DVM to check the logic board power connections? I would star their making sure the logic board was getting power.

You should get the schematics and board views for the display to dig deeper.

Был ли этот ответ полезен?

Оценка 1

Комментарии:

I got the schematics, and ordered a DVM to test the logic board. This is my first project but I intend to see it through to the best of my ability. Thanks for your comment!

из

Добавить комментарий

Добавьте свой ответ

Kevin McAndrews будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 1

За последние 30 дней: 2

За всё время: 31