Перейти к основному содержанию

Model A1419 / Late 2012 / 2.9 & 3.2 GHz Core i5 or 3.4 GHz Core i7 Processor, ID iMac13,2

328вопросов Показать все

White screen and no booting. Switched Fusion Drive to SSD. No Change

White screen with no apple logo. I installed an ifixit SSD Micron 1000 GB. Installed into the iMac after loading OSX Catalina onto the SSD. Still white screen even after doing PRAM reset. Not sure if there’s also a problem with Video Card or motherboard. Asking for help.

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 2
2 Комментариев

@jake1776 - Just to make sure we understand things: Your system had a White screen before you altered things - Correct?


Yes, white screen was before I changed to SSD. Before computer went to white screen with no logo, it was almost booting up and getting like half way though the boot up with Apple logo. Occasionally, it would boot in completely and that may be by pressing PRAM reset and other key codes like 30 times. eventually I could never boot in. By then, it was only a white screen. I pre-loaded SAS with Catalina, we are still at a white screen. I removed the SSD several times and tested it again by plugging it into my other 27" iMac (2015 model) and sure enough, it is working and has Catalina OSX working on it. I put it back into my late 2012 iMac. still a white screen. Is there another part I need?

If you think I can't fix it, can I trade the 1TB SSD for a 2TB SSD so that I can still use these parts on my 2015 iMac. (I figure if I can't get the 2012 iMac working, maybe I just use it for spare parts if the 2015 ever breaks and go ahead and take this time to swap the 2TB fusion HDD with a 2TB SSD.



Добавить комментарий

2 Ответов

Наиболее полезный ответ

White screen is usually indicative of a hard drive issue. Try disconnecting the internal drive and hooking it up externally and boot from it that way. Let us know your results.

Был ли этот ответ полезен?

Оценка 2

3 Комментариев:

Thank you for the idea. I removed the SSD and hooked it up via usb with no internal HD inside iMac. I tried turning on and no change--white screen. Then I tried holding OPTION key after chime and still no change--white screen. I should note that it's weird that it's turning on with the chime/white screen about 3 seconds after I plug it in. It's no longer waiting for me to push the startup button. Not sure if the start button thing means anything.

Is replacing the Logic Board necessary at this point? If so, do I replace the CPU at the same time? If not, can I swap the CPU on my motherboard and put it onto the new logic board? Would you recommend loading a different OS onto my SSD. (right now I have Catalina). according to the Mac specs, the earliest computer that Catalina works for is a late model 2012 which is this model.

Would you recommend just ditching the computer altogether and selling it for parts?


Also, could the RAM be bad? Does RAM have anything to do with white screen? Is it possible the video connector is bad? I notice when I press OPTION, COMMAND, P, R, for PRAM reset, it does give me the multiple chimes, so it is at least recognizing my keyboard. As I said earlier, when I plug the SSD into another working iMac, it instantly recognizes it as Catalina, but then that is a 2015 iMac and not a late 2012.


We have to try to boot from a KNOWN good drive with a system on it. If the old hard drive was running, try booting from it.If you have another Mac with a compatible system, you can hook it up in Target Mode and try to boot from it.


Добавить комментарий

No new thoughts on this?

Был ли этот ответ полезен?

Оценка 0

2 Комментариев:

@wellconnected - Sure lots of thoughts!

∙ Why is the world not round (egg shaped)

∙ Why we don't breath nitrogen as its more plentiful!

Did you even try what @mayer stated?

If you did and you still have issues how about creating a new question with all your original symptoms and blow by blow steps you took.


Hi Everyone, I am having this exact problem. I've removed the fusion drive and installed a new SSD. Still getting a white screen with no apple logo or progress bar, but i do get a chime. Ive reset SMC & PRAM, but when i've tried safe mode, and internet recovery it stays on the white screen. Did you guys ever find a solution?


Добавить комментарий

Добавьте свой ответ

Jeremy Morris будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 1

За последние 30 дней: 4

За всё время: 167