Перейти к основному содержанию

Repair guides and support for external portable storage by Western Digital including the My Book series, My Passport and others.

219вопросов Показать все

My Passport for Mac - Not showing up

Hi!

I am having a problem with my external hard drive. It doesn’t mount properly and show up. Have tried multiple Mac and Windows computers. Unfortunately, our picture library from a Mac is on there and we are hoping to recover it.

In Mac Disk Utility it shows up as disk2s2. Trying to mount gives error 119930868. First aid also fails.

The WD Drive Utilities says the SMART status failed and the drive tests fail.

I tried a bit with Photorec and it seems to work. But it needs another week plus of time and all the organization/date stamps etc will be gone, I believe.

Anyone have any advice how to try to recover the drive itself or to recover the photos in the original library with the organization?

Thanks a lot!

Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка 0
Добавить комментарий

1 ответ

Выбранное решение

Another one bites the dust. These WD, etc. external drives. People stop buying them. Just look at how often this problem comes up on IFIT. To repeat, buy separate SSD/HDD and external case. Both parts replaceable. Much more reliable and easily upgradable.

Having said that, open up the case to see if the HDD has a standard SATA connector. If it does you are lucky. Just buy a separate external case and install drive. If it still doesn't work then the drive is defective but you may be lucky and Photorec will work well with the new external case .

The question is, is it the WD controller or the drive itself that is the problem - or both?

Был ли этот ответ полезен?

Оценка 1
Добавить комментарий

Добавьте свой ответ

M L будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 1

За последние 30 дней: 8

За всё время: 228