Перейти к основному содержанию

Отремонтируйте ваше устройство

Обучение ремонту

Магазин

Model A1297 Unibody: Early 2009, Mid 2009, Mid 2010, Early 2011 & Late 2011

620вопросов Показать все

MBP 17 2009 not booting on cold boot.

I suspect this MBP 17 2009 has potentally multiple issues.

  • For one the dedicated GPU (9600m gt) seems to be broken. I cannot boot without it being disabled (nvram fa4ce28d-b62f-4c99-9cc3-6815686e30f9:gpu-power-prefs=%01%00%00%00 or with nomodesetfrom a live linux usb stick ). The internal gpu (9400m) works fine then though. I checked the usual suspect c7771 capacitor (https://www.youtube.com/watch?v=pvy-WrDd...) but I measured 1.15V, which seems normal, right? Anyway as I’m fine with only the internal GPU working, this issue wouldn’t be as daunting IF
  • the MBP won’t boot from cold. IF it is shut down for longer than 2 hours, it will attempt to boot for a second after pressing the power button, then it dies. The only workaround to solve this is to reset the SMC and NVRAM again. But then I also have to disable the dGPU again, which is rather time consuming (I’m aware that I could remove some .kext so the system won’t try to booth with the dGPU, but I dont know which to remove as the internal GPU is a nvidia one as well). After this I’m able to boot again normally. Once it runs, I can shut down and reboot timely without any issue. It does not seem to matter if I run it on battery only or per magsafe.
  • CoconutBattery shows a battery capacity of ~80%. The disk is a fairly new SSD. Already wiped and freshly setup macOS.

Are there any other capacitors that could be faulty and trigger such a behaviour? What else could I try, to get the MBP in a rather stable/reliable state?

Thank you for your help.

EDIT1 SSD is a 1TB Samsung EVO 860. Coconut Battery Screenshot (I would probably not trust it, as I have to reset SMC and NVRAM kinda often):

Block Image

EDIT2 any ideas?

Ответ на этот вопрос У меня та же проблема

Это хороший вопрос?

Оценка 0

Комментарии:

As you already have CoconutBattery take a snapshot of the apps main window and post it here for us to see Adding images to an existing question so we can make sure your battery is in good shape.

You state you have installed a new SSD who's and which model?

из

Добавить комментарий

2 Ответов

I’d replace the logic board. I had this exact issue on a 2013 MacBook Pro and once I replaced the logic board, all was back to normal.

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

Try using gfxcardstatus to disable the GPU

http://gfx.io

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

Добавьте свой ответ

Metadoro будет вечно благодарен.
Просмотр статистики:

За последние 24часов: 0

За последние 7 дней: 0

За последние 30 дней: 0

За всё время: 18