Перейти к основному содержанию

Model A1418 / Late 2013 / 2.7 & 2.9 GHz Core i5 or 3.1 GHz Core i7 Processor

255вопросов Показать все

A writable disk is required. : (-69772) - NVMe SSD Upgrade

I have iMac Late 2013 model and it didn't have SSD installed by default so I have decided to upgrade it with NVMe SSD.

For this purpose, I have purchased 2 devices:

  1. M.2 NVME SSD Convert Adapter Card
  2. Kingston 1TB A2000 M.2 2280 NVMe Internal SSD

All setups got completed properly and worked for around 1 week without any issue. One day I decided to transfer my whole work data to an installed SSD because it was almost empty.

During this copying process around 120GB of data get transferred but suddenly it gets stuck with some error. This is my current situation of installed NVMe SSD, I have recorded a video for this and uploaded it on Google Drive:

Video

It is stopped me to write something on it so I have decided to format this but it giving me Writable Disk Required king of error message

I have read different posts related to similar issues but everyone is struggling so I have decided to create a new post with all my recent information.

Adapter and SSD both I have purchased new from Amazon. I don't know why this kind of problem occurred whether it's because of heavy data transfer in one shot.

Please share your opinion so I can solve this problem.

Отвечено! Посмотреть ответ У меня та же проблема

Это хороший вопрос?

Оценка 0
Добавить комментарий

2 Ответов

Выбранное решение

Sadly the M.2 blade SSD won’t work in your system.

Between the adapter and SSD when moving large amounts of data the data and control flow data becomes corrupt. Nothing you can do here other than replace things.

You really need to get either a real Apple blade SSD or get one that is designed from the ground up to meet the Apple I/O interface. These adapter solutions just don’t hold up.

Here’s what I would get: iMac Intel 21.5" (Late 2013-Mid 2014, Select Models) Blade SSD Upgrade Bundle or a real Apple unit Custom Apple 1TB PCIe 2.0 four-channel interface SSD

I’ve taken out so many its not funny!

iMac Intel 21.5" (Late 2013-Mid 2014, Select Models) Blade SSD Upgrade Bundle Изображение

Продукт

iMac Intel 21.5" (Late 2013-Mid 2014, Select Models) Blade SSD Upgrade Bundle

$159.99

Был ли этот ответ полезен?

Оценка 1

5 Комментариев:

Yes, your answer really made me sad because my expenses went into the garbage.

But I have watched in multiple youtube videos, people upgrading their MacBook with the same devices so after opening my iMac I have checked the port and then ordered an adapter and SSD.

Around 1 week, this worked for me properly then after one day I have transferred around 100GB of data and during the data transfer process, it got stuck.

Regarding this I have thought 2 things to solve this problem:

1) Take out and again insert the adapter and SSD

2) Check for Kingston SSD Firmware update and see what will happen after that.

https://www.kingston.com/us/support/tech...

What do you suggest in this? Or you stick with your answer?

But initially it was working fine for me so I am hopeful to get success :)

из

@siddharth3322 - There is a lot of mis-information out there! It also gets into the window of stability! Sure you can boot up and use the drive with light work loads as your not pushing the I/O enough to bring it to its knees.

Not the first time we've seen this!

We've seen this same effect with HDD's when people put in faster fixed speed SATA III (6.0 Gb/s) HDD/SSD's into SATA II (3.0 Gb/s) based systems encountering the same effect! Again, crapping out when pushed.

Be aware there are some special SATA III drives which auto sense the systems I/O speed and match it! As an example the Samsung 2.5" 860/70 EVO/Pro drives. So you need to review the given drives spec sheet to discover if it works in your system.

Getting back to your issue

Here the NVMe/PCIe interface does not offer this heavier SATA dialog cross-check in the I/O flow, it only offers a simple CRC checksum and the buffer space of the given drive may also get in the way as its not deep enough before being over-run.

Apples custom SSD and 3rd party SSD drives which are fully designed to match, leverage the additional data lines to have a dialog between the system and SSD to control the flow.

The M.2 SSD's don't offer this setup in the same way Apple designed things, so the lines are not present in the M.2 SSD to be routed to the needed pins of Apples interface.

So if Apple embraced the M.2 spec I wouldn't have an issue, as much as I would have liked it (as well as you) Apple did there own thing as such we are handcuffed to their custom interface and drives which are 100% matched to it.

But I can walk across water! Let's look at it this way...

Its the start of winter the lake is just icing over is is safe to walk across, yet people more north of you are saying they are having a hockey game on a local pond. So is the Lake safe to walk across Vs the Pond? The volume of the water and air temp controls the point of icing up! So don't always assume if someone else is playing a hockey game your local body of water is safe to cross! Besides, you'er a basketball fan not hockey fan ;-}

из

As far as Kingstons T/N on firmware So you are running Windows or macOS? how do you think you could upgrade the SSD's firmware?

It also doesn't even apply here either! As the issue is not a firmware issue. I've seen every major vendors SSD's fail with these adapters. Even Samsung's which is the major maker of Apples custom SSD's!

I've fixed quite a few systems and I can tell you when I get one of these systems in with drive issues I hate telling the owner the bad news.

I've had people cry and tell me I'm wrong spitting in my face in anger! I then pull out the very full drawer with hundreds of M.2 SSD's and adapters that I've collected over time. At which point the anger is aimed at the snake oil salesman who made the bold statement this solution works and is stable.

So you have my answer, I don't get paid here. My goal is very simple to make sure people get the correct information to help keep systems from the land fills!

Repair, Reuse then and only then Recycle! Support the right to repair in your country! A throw-away society is not the solution!

из

@danj Firmware I install through windows system so I have to do tedious work of opening the iMac and take out the SSD.

I got many things from your multiple replies so now I will purchase one NVMe SSD enclosure like this and use my SSD externally.

https://www.amazon.in/ORICO-Enclosure-US...

Already I have a Late 2013 iMac so rather than doing further expenses in the same, it is time to move ahead for M1 cheap iMac in near future.

Thank you sir for all your suggestions :)

из

@siddharth3322 - Thats another good reason! As you don't want to be pulling out your drive every time you need to refresh the firmware.

из

Добавить комментарий

Let me add last comment to this question because now all things sorted out.

Overall as per my understanding because of heating issue my NMVe SSD stopped working because I have plugged SSD within motherboard through cheap market adapter without any kind of thermal paste.

After removing from iMac, I have tested NVMe SSD with enclosure to other computers but it didn't work so I have to request for the replacement and I did it successfully and I got the new piece from the company.

Now I am using it with enclosure for my regular usage and its working great though enclosure is heating too much at the time of heavy load.

Был ли этот ответ полезен?

Оценка 0
Добавить комментарий

Добавьте свой ответ

Siddharth будет вечно благодарен.
Просмотр статистики:

За последние 24 час(ов): 4

За последние 7 дней: 20

За последние 30 дней: 42

За всё время: 4,475